[Solved] Why PCB render / 3D viewer doesn't show the models of components?


I’m using Ubuntu 21.10 + Kicad 5.99. After switching from schematics editor to PCB editor (importing all components from schematics, etc.) I don’t see the components on PCB render (3D viewer), only pads for them:

Did I mess up somewhere with library installation or how to turn it on?

Installation steps:

sudo add-apt-repository --yes ppa:kicad/kicad-dev-nightly
sudo apt update && sudo apt full-upgrade -y
sudo apt install kicad-nightly kicad-nightly-footprints kicad-nightly-libraries kicad-nightly-packages3d kicad-nightly-symbols kicad-nightly-templates -y

About a week ago I did a re-install, and I had to change the path to the 3D libraries:

I did not look into it further then, but if the path variable is initialised wrongly by default, then it’s either a bug in KiCad or a packaging issue.

Apparently there also is a recent path change in the setup:

1 Like

Thank you! That worked!

I’m glad it’s solved for you but I’m still wondering if this should be turned into an issue on gitlab.

Maybe let it sit for some time because of the change eelik mentioned, but if the default path for the 3D libraries is set up wrong, then somebody should do something about it sometime :slight_smile:

I just tried on Windows completely from scratch after uninstalling and installing everything, and paths work OK. I can’t say if old setup and the latest nightly update can mess up the 3D models somehow, and this was only Windows, not Ubuntu.

Windows works fine. Ubuntu 20.04 till 21.10 have this issue.

This is why I specified the OS in the original post.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.