[SOLVED]Warnings "Track has an unconnected end"


I have a working PCB made with Version 5.x that is running well with no errors / warnings.

I installed Version 6.0.0 on Win 10.

Since then, when I want to do improvements to the project, two things happen.
ATmega328-PU is not found in Library, formerly it was.

I updated to ATmega328-P.

But DRC run on the PCB editor gives many Warnings “Track has an unconnected end”.

Some (very few) I can correct deleting the track and redrawing it. But some 10 remain with no correction possible.

Any ideas ?

Thanks a lot,

That’s a strange thing happening when editing tracks in V6. You have to do “Cleanup Tracks & Vias” to get rid of the warning.

[EDIT] Seemingly the PNS router produces track segments connected to a node on one end and dangling on the other. Since this happens congruent to the track you do not see that. If you are interested, hit ‘K’ to see the tracks “inner workings”.


Thank you, Solved !

Kind regards,


Yes it does seem to be more prevalent in V6 largely because the DRC now detects it. In V5 you still had them hidden under pads etc.

Yes, keep in mind that a lot of boards that passed 5.0 DRC and don’t pass 6.0 DRC are because 6.0 DRC has a lot more checks built in.

This one bit me too. I can suggest turning off everything but Tracks and Vias in the Selection Filter in the lower right corner. Then run DRC and step through the errors and you will quickly find and be able to delete the “stubs”.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.