[SOLVED] Use KiCad exported VRML in footprint

It was suggested I make a new thread for this issue.

I’m working on a project that will make use of several daughter boards, so for ease of viewing in KiCad I export the daughter boards as a VRML in Pcbnew. I’m aware of step being the preferred format for mechanical use but I want to visualize the complete assembly with traces and silkscreens.

Based on previous threads covering the same or similar issues it was stated that 1 vrml unit = 0.1in. So you would expect in the VRML Export Options that with an Output Unit of 0.1 Inch it would have a 1:1 scale when you import the model into a footprint.

In this thread it was said to have been an issue and that it was fixed. However, either I’m doing something wrong or something else has changed since then that has caused this issue to reappear. In order for me to get a usable model I have to export with Output Units set to Inch and the XYZ scales set to 10 in the footprint 3D Settings to get the correct sizes.

KiCad version: 5.1.10
OS version: macOS 12.0 Monterey Beta

So if I understand you correctly, then you first extorted at scale “0.1” because you “read that somewhere”, and then are surprised you have to scale it with a factor of 10 again upon import?

KiCad is not standing still. Even though KiCad V6 is being delayed for over half a year now it’s overall moving and improving at a quite fast pace.

I had never exported in .wrl format before, so I did it to answer this post.
KiCad V5.1.10 lets you choose a “Output Units” during export, and because I live in the metric 95% of the world I chose mm for both the Units and the Output Units:

image

After that I imported the exported file in FreeCAD and verified that the scale factor was correct. FreeCAD shows the PCB as 50mm.

… But that was the second time I did the export.
First time I made an error that I almost did not notice. I used mm as Units, but used meters as Output Units, and this resulted in KiCad thinking the PCB was 50um wide instead of 50mm.

Edit:
The “50” in the FreeCAD screenshot are millimeters. I just turned of the “mm” in the settings.

Honestly I must have been really tired last night, I just tried to do it again with a 0.1in Output Unit and it works like I would expect it to. I must not have set the Grid reference point when I originally tested that size so it was too far away to be rendered in the footprint 3D Settings. This thread can be closed since I figured out the problem on my side.

Threads now automatically close after 3 months. We’ll let it ride. This software allows you to change the original title to add solved. Any regular user with enough ‘cred’ by the software’s standard can also edit the title. Not quite completely decentralized administration but works well for the most part.