[SOLVED] Unable to run KiCad after upgrading Linux Mint

I just upgraded to Linux Mint 20 and now when I try to run KiCad I get the following error

kicad: /usr/local/lib/python3.6/dist-packages/wx/libwx_gtk3u_core-3.0.so.0: version `WXU_3.0.5’ not found (required by kicad)

The same thing happens if I try to run pcbnew, eeschema or pcb_calculator. I have 5.1.6-202005120818+c6e7f7d~86~ubuntu20.04.1 installed but I get the same error when installing 5.1.5+dfsg1-2build2 from the official Focal repo.

I’ve tried installing wx3.0.5 by adding ‘http://repos.codelite.org/wx3.0.5/ubuntu/ focal universe’ to my repositories but I still get the same error.

There are two flavours of mint. One derives from ubuntu and one from debian. Your package seems to indicate it is from the ubuntu repo so it will only work on mint derived from ubuntu. https://kicad-pcb.org/download/linux-mint/

I’m using the one derived from Ubuntu, and had been using ppa:js-reynaud/kicad-5.1 since using Linux Mint 19.3 without any issue

New LMDE images are released only sporadically as updates track Debian. Most Mint users are not aware of LMDE. So a version number of 20 is the Ubuntu derivative.

I wonder why it looks for /usr/local in /usr/local/lib/python3.6/dist-packages/wx/libwx_gtk3u_core-3.0.so.0

Just went to Mint MATE 20.0 myself. It was a fresh install, I was using Mint MATE 18.3 before.
I used the PPA to install Kicad, no issues during install. I have started Kicad and Project loader started ok. I have not loaded a project yet and tried eeschema or pcbnew. I had to get my network drive working first. and set up custom libraries.

Did you do a full Mint install or upgrade from 19? Maybe that could be the issue?
I’ll erpost this thread after I try loading a project.
OtG

In case anyone else might run into the same issue, I’ve solved it by deleting the /usr/local/lib/python3.6/dist-packages/wx/ and wxPython-4.0.4.dist-info directories.