[SOLVED] The current configuration does not include the library

I just update KiCad from 6 to 7.0.2.
I have a personal library that I moved over to version 7 called “01_Symbols Library.pretty”.
When I open the Footprint Editor, I can see my library and I am able to open each footprint in the file.
When I run the ERC, I am getting errors stating, "The current configuration does not include the library ‘01_Symbols Library’.

I have searched the internet, but I am unable to find any information regarding this error and what to do to fix it.
Thank you for your help.

Hi, and welcome @dnvm84

You need to add your personal library to the list of available libraries. When you installed 7.0.2, Kicad only installed the Kicad libraries.

To install your personal libraries go to
Preferences / Manage Footprint Libraries / Global Libraries.
Left click the + icon (bottom left of opened window)
Click the Greyed rectangle in the “Library Path” column
Click on the black folder icon
In the newly opened window, find your library, highlight it, click open.

This will place your library in the global library list.
Give your library a “Nickname”, tick Visible & Active
Click OK.

Nicknames determine the position of your library in the list of libraries available in the PCB & Schematic Editors as discussed here.

If you have Personal Symbol libraries, you will have to follow the above procedure to install those libraries into the Schematic library list.

To avoid confusion within this forum, it is best to use Footprints and Tracks when dealing with the PCB and Symbols and Wires when dealing with Schematic

Hello, thank you for the quick reply.
I followed your instructions, but when I ran the ERC, it is still giving me the same error message.
So, I looked at it again and realized that the name of the file did not match the nickname. So, I changed the name to match the nickname.
I went back into the Footprint editor deleted the added library (had the different name), then added the library again, this time with the matching name.
Restarted KiCad.
Still getting the same error message.
I have attached screenshots, maybe they will help.
Thank you again.

ERC Error Message 2023-04-23

Footprint Editor Library List 2023-04-23


You seem to be dealing with two problems.

You have the ERC with missing symbols and you have a Footprint library with the newly added “01 Symbol Library. pretty.”

Does the 01 Symbol Library contain Symbols or Footprints?

The Schematic seems to be missing Symbols, according to the ERC. The ERC is for the Schematic (symbols) and the DRC is for the PCB (footprints).
Symbol Libraries have the suffix “kicad_sym”. and footprint libraries have the suffix “pretty”.

Please check to make sure you are adding Symbol libraries and the Footprint libraries to their correct lists.

Also, the “Nickname” doesn’t have to have the same name as the library, see the link I posted earlier.

Okay, I thankfully still had the symbols library.
I renamed then so I don’t confuse myself again.
Everything seems to be back up and running in regards to this issue.
Now I have to figure out all of the new ones.
Thank you for your help.

1 Like

How do I mark this issue solved?


I’m pleased you sorted the problem. :slightly_smiling_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.