[SOLVED] Symbol library is not writeable

I saw the different threads for kicad 6… Unfortunately I am under Kicad 7.07 and the library is migrated to the new kicad_sym format. When I want to add a new symbol, the Symbol Editor refuses.
I have write access to the libraries directory on the network (using Kicad on Windows 10)
I would be grateful for any hints.
Best regards

The standard libraries are read only . . . if you want to create a new symbol or edit an existing one you need to create a custom library and add the new/modified symbol to that.

FAQ here: Kicad 7 Tips 'n Tricks when making Personal Symbol Libraries

Oh I am sorry, I did indeed mean a custom library that I wrote to before and save my schematic symbols to.

Are you trying to save in the old format? Old format libraries can be read but not written. Migrate them to the new format first.

It is in the new format, .kicad_sym

(kicad_symbol_lib (version 20220914) (generator kicad_symbol_editor)
  (symbol "DYSI-97PS(K)" (pin_names (offset 1.016)) (in_bom yes) (on_board yes)
    (property "Reference" "U" (at -8.89 -19.05 0)
      (effects (font (size 1.27 1.27)))
    (property "Value" "DYSI-97PS(K)" (at 3.81 19.05 0)
      (effects (font (size 1.27 1.27)))

First few lines of the file

I just made a new library in this directory, that works without problem, but I still would like to modify my existing.

Did you add your personal libraries to the list of Global Libraries in Preferences /Manage Symbol Libraries?

If it’s already a custom library do you have user access ? can you get access to the files and folder with write permission from outside KiCad ?

This FAQ may help: KiCad 7 Beginners Guide to Personal Symbol and Footprint Libraries

Yes I do have access
Yes it is added.

I attach the file, maybe someone sees something off
AlgraTecLib.kicad_sym (38.9 KB)

I added your library to my V7.0.6 KiCad and it works with no issues . . .

I get this on 7.0.7

I can write to it . . .


Have you tried removing it, shutting down KiCad, reopening KiCad and re-adding it ?

Also, can you read and place other items from that library?
Is your folder containing that library write protected?

Check the file permisions of the file itself and of it’s parent directory via the command line or a file browser.


I removed, added, exited restarted and still no dice. I should have full r/w access

I can add new files to the directory and I can edit the AlgraTecLib.kicad_sym (added and removed a line with notepad++, saved, File edit date got updated

1 Like

But kicad still doesn’t agree with me

I added these three symbols to your library, then placed them on a schematic from your library.

There must be a permissions problem.

Try moving your library to another location. eg. Documents or somewhere you know has write permission.

Do you have write permission for the other personal libraries?

1 Like

That + sign at the end of the permissions string indicates that the files and directores have associated Access Control Lists. See this for an introduction to Linux ACLs:

getfacl(1) will show my more details about the effective permissions. Possibly the ACLs were set up that way for some other purpose.

Also, cygdrive? Is this a Windows filesystem mapped to Linux?

As written in the first post, I am working under windows 10 with windows kicad 7.07.
As I am coming from a linux background I always have a cygwin window open.

has a bit less info…

S is a windows network drive on some windows server.

I made a new library in the same directory to which I can write so I don’t understand why it doesn’t like my algrateclib kicad_sym…