Solved. Symbol Library - I'm going slightly mad (unwanted symbol in power unit, 4xxx)

I always maintain/use my own symbol libraries, and am just now updating my 4xxx one.
Everything is fine except symbol “4066”.
The fifth unit (the power symbol, “Unit E”) has the logic symbol superimposed, and it’s impossible to get rid of. Unit A…D are OK.
Screenshots of 4066 Unit A and E:

Now, all other symbols in my library do not have this issue, the power unit is just a rectangle.
Here’s the extract from my 4xxx.kicad_sym file showing the 4066 (wrong power symbol) and the 4069 (correct power symbol). I see no difference. “Symbol properties” are the same for both symbols, except for the “Alternative” on the 4069.
4066_3.txt (13.0 KB)

So the big question is: which other files store symbol information that could provoke this behaviour?


(KiCad 6.0.8, Lubuntu 22.04)

It looks like you are using some older version of the library.
In my version (Also KiCad V6.0.8) Unit E looks like:

Units A through D have also been modified. They no longer show both the inverting and none inverting gate signals:


You misunderstood me, sorry if I was unclear.
This is MY local library, not the standard/distributed one. I can submit it here, no problem, if you like. I already submitted the relevant part of the 4xxx.kicad_sym library as .txt.
Only this single symbol creates problems. All othes (gates, FFs, counters…) behave perfectly (I’ve modified them all).
I’m completely stumped. The library file is OK, so somewhere else there has to be… well, something.

Theoretically they are just graphic lines inside a filled rectangle.

Did you try opening the symbol editor and deleting those lines from inside the rectangle or:
Did you try deleting the entire rectangle and its contents then redraw the rectangle or:
Did you try deleting all part E and redrawing the rectangle with the two pins?

It seems to me that your workflow to create this symbol was:
Create, modify or copy (whichever) the symbol for A.
B,C & D were just A copied with pin numbers changed.
A was brought over to E and a filled rectangle was placed around, one pin deleted, two pins renamed and moved, but, the A graphic lines were not removed before saving?
One of the above solutions should hopefully work.

Only the symbol lines in your file look like:

  (symbol "4066" (in_bom yes) (on_board yes)
    (symbol "4066_0_1"
    (symbol "4066_1_1"
    (symbol "4066_2_1"
    (symbol "4066_3_1"
    (symbol "4066_4_1"
    (symbol "4066_5_0"
    (symbol "4066_5_1"
  (symbol "4069" (in_bom yes) (on_board yes)
    (symbol "4069_1_0"
    (symbol "4069_1_1"
    (symbol "4069_1_2"
    (symbol "4069_2_0"
    (symbol "4069_2_1"
    (symbol "4069_2_2"
    (symbol "4069_3_0"
    (symbol "4069_3_1"
    (symbol "4069_3_2"
    (symbol "4069_4_0"
    (symbol "4069_4_1"
    (symbol "4069_4_2"
    (symbol "4069_5_0"
    (symbol "4069_5_1"
    (symbol "4069_5_2"
    (symbol "4069_6_0"
    (symbol "4069_6_1"
    (symbol "4069_6_2"
    (symbol "4069_7_0"
    (symbol "4069_7_1"
    (symbol "4069_7_2"

So "4066" would be your symbol name and for "4066_m_n", m would be the unit number and n would be the variant number. 0 means “all units” or “all variants”, respectively. In above, that means all elements defined for "4066_5_0" will also show up for "4066_5_1" (and possibly "4066_5_2", for De Morgan variants).

So you probably need to uncheck some Common to all … check box for some elements of unit 5 (or cut the symbol in KiCad, paste in any text editor, change the appropriate 0s to 1s or move some elements from …0 to …1 variant, select all, copy, and paste back into KiCad).

Thank You, Thank You.
You nailed it. The problematic header/section was this one:
symbol "4066_0_1"
It should be “4066_1_0”, and units B, C, D need to be edited again.
The nasty thing is, you can’t change it in the GUI, you need to edit the 4xxx.kicad_sym file in a text editor directly.

But it’s fixed and I’m happy. Another trap to add to my KiCAD notes.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.