SOLVED: Some components don't show up in 3D view

EDIT: I partially solved my own problem. After assigning whatever footprints in Eeschema and exporting the new netlist, there’s an option in Pcbnew to exchange footprints to whatever the current netlist says the component should have. This solved the problem for almost all the components. There are a few Molex connectors that haven’t updated yet, but that’s probably because I’ve edited them in Pcbnew.

I attribute the mismatch between footprint names to having originally designed this board in KiCad 4 and then upgrading. I’m leaving this here in case someone in the future has a similar problem.

Here’s something annoying. Most of my components don’t show up in 3D view, despite them being installed on my machine and being able to view them individually, like when I assign footprints.

Here are two examples, but since I’m new to the forums I can only post one image. In the top snip, Q1 and Q15 are the same transistor, and I’ve assigned the same footprint to each of them. Only one shows up in 3D view. In the bottom two snips, I’m showing two ICs (U9 and U8) that don’t show up when I view the board yet do individually when assigning footprints:

These are not custom footprints, they’re built-in footprints. I know I’ve got them installed. Why won’t they display? In fact, MOST of the components on my board don’t display. I’d like to include the board view in a presentation to my team, but this looks terrible.

Application: kicad
Version: (5.0.2)-1, release build
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:

Do your components have 3D models installed? They would be in

If so are they linked to your footprint?

Like I said, these are built-in footprints, not custom. I can view their individual 3D parts in the library browser.

My edit to the OP reflects how I solved this problem for built-in components.

In PcbNew there is a new method with V5 to update the project information.
Main menu/Tools/Update Footprints from Library…

This is not expected to fix your 3D-model library connections, but may help with other issues in the future.

This might be a good read for you in this case. I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

And also Converting KiCad version 4 projects to version 5 (Remap a project) (I really should add some information about what happens with the 3d model side of things if one does not install the v4 3d models.)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.