[Solved] Possible Symbol Properties bug in 7.0.0-rc1?

Looking for confirmation of bug.

In this instance, but it doesn’t seem to matter what property is changed.
Open Symbol Properties.
Change something. I changed “show name” & “italic” in Reference.
Clicked OK and up came the error box with an incorrect notification.
Clicked OK in Error box
A new empty fifth Field opened without prompting.
Clicked the rubbish bin symbol
The new fifth field was deleted.
Click OK and the properties box closes and the changes to the symbol show.

There seem to be a few unnecessary steps to change properties.
Would others test please and confirm before I report.

Application: KiCad Schematic Editor x86_64 on x86_64

Version: 7.0.0-rc1-unknown-c5ef51d688~164~ubuntu20.04.1, release build

wxWidgets 3.2.1
FreeType 2.10.1
HarfBuzz 2.6.4
FontConfig 2.13.1
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux Mint 20.3, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Jan 7 2023 20:32:58
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.68.0
ngspice: 38
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:

What was the fifth field? ( That might appeared after checking exclude from simulation. )

Current error pops up if you completely erase the Value from the Reference field and click somewhere else.

This is the result of clicking OK in the Error window.
I did not add that fifth field.

All I did was tick a box. No erasures.

This seems like a bug to me… It doesn’t reproduce for me though.

Agree about a possible bug. I wanted confirmation before reporting.
Have not struck this behavior in any 6.99s before. My last 6.99 version was Jan 3.
I’ll wait for other replies first.
Thanks for your time.

1 Like

Went back to 6.0.10 and found a similar problem.
This time as soon as Properties is opened a new field is generated. If named then closed, upon opening again, yet another field is generated.
New fields can be deleted, the warning goes, and the Property window will close.

All very strange, but I suspect it could be me.
Anyone with any ideas?

Cannot confirm with Win11.

No 5th line, no error message, just works.
Erasing the reference’s value and clicking somewhere brings up a message that references can’t be empty, which is fine.
So all good here.

Can you check the Field Name Template List in the Schematic Setup of global Preferences for that empty field entry?

If I place there an empty field I can save this w/o any error. If I edit any symbol for editing I can’t close this w/o the same error.
Edit: Concluded: With this “special”/wrong setting I can confirm this bug. But this should be prevented in the template field name dialogs.

Thanks @hsjmk

That wasn’t the problem.
I had a big clean out of the computer and now the problem has disappeared on both 6.0.10 and 7.0.0-rc1.

Good to hear that. Yep, sometimes it’s just a necessary power cycle, uninstalling a win patch or Monday blocking reliable software doing its normal stuff. Or do you mean something that has to do with a vacuum cleaner :thinking: :sweat_smile:

More like a sledge hammer… reformat C drive. :japanese_ogre: