[Solved] Pcbnew 6.99: Cannot see properties panel

Even if selecting “View properties panel”, I cannot see it on my screen. What am I doing wrong?

[EDIT] Most recent nightly, Win 11.

property panel is currently blocked behind a paywall the advanced settings.

1 Like

Ok, thanks. Embarassing to ask: where (or what) are the advanced settings?

Need to select an item, then Right-Click it and click properties in pull-down.

I meant the property pane next to the Appearance Manager. Not the plain vanilla properites (‘E’ or context menu).

That menu entry isn’t supposed to be there… will fix soon

Search for kicad_advanced here: Where are the configuration files (settings, library tables)?

If you’re a developer, you should figure it out, if not, there’s probably a good reason why it’s hidden.

No, I’m no dev. Just was triggered by a bug report about the property pane and was wondering what that is.
I certainly won’t touch what is reserved for higher beings :grinning:
Marking the issue solved.

[EDIT] Maybe testing performed by non-devs could be useful at times…

The devs will make the feature visible once they require testing.

At the moment they probably know that it is broken and don’t want to be flooded with bug reports.

The properties panel is hidden right now because it is only half-complete. It is currently unlikely it will be ready for V7, but who knows.

I don’t recommend people turn it on unless they are working on testing it specifically, because there is high chance it breaks your design at the moment. And bug reports of “the properties panel broke my design” are not very useful for us right now.

1 Like

:honeybee: ?

I’ll go back to ‘beehaving’ now. :wink:

1 Like

LOOOL. Talk of a typo…

I get it. I’ll behave and hold back.

You are welcome to turn it on if you want. But just be aware the reason it is turned off is because it isn’t done, and we aren’t particularly looking for testing right now because testing of something half-complete is not a good use of time in my opinion.

Yeah, sure. Got it. All’s good.

1 Like