[Solved] PCB Exporting .STEP: Scaled models detected and no export of that model

In one PCB Project, I have a couple of components 3D modeled using FreeCAD.

WHAT’S I NOTICED
I already noticed that when I design the footprint, it respect the measures,
When I design the 3D Model in FreeCAD, it’s exported correctly (I already 3D printed several things), but when imported into KiCAD, I don’t know why, I have always to scale it for some reason.
But if all it’s made 1:1, why should I scale it again and not just repositioning it?
No idea

WHAT’S OCCURRING WHEN EXPORTING
When I export the PCB as .STEP (as .WRL: no problem), appears this window:
image

as result, into the .STEP file, there are all the KiCAD native components, but NOT mine ones
Which is irritating, because it’s nor written: it will be not exported. But it tels: Model scaling is not reliable.
ok it decides do not export them for some practical reason: I do accept BUT why doen’t it export them?
Yes they are scaled, but because something occurs when imported (as I said above)

HENCE
WHY when I import a component that’s correctly sized in CAD, exported in .STEP and imported into KiCAD should be always 1.8-2 times bigger than what should it be?
is there a way to impede this and to be able to avoid all these issues at once?

Can you help me on this please?

You did not post enough info to be able to diagnose the problem but, I suggest you consider:
• FreeCad setting is for mm (Pref’s>General>Units
• Also, ensure your STEP export is for mm (Import-Export>Step…
ADDED: Also try checking ‘Legacy’ in the Step Export panel

• Some poorly designed models will successfully export from FreeCad but, the Step may have problems (somewhat like a bad .STL that needs repair/healing but also exports successfully)
• Did you export from StepUp or from PartDesign or Part workbench?
• Did you export a Step of a Compound of the model or of the Last Item in the Tree or the full Tree?
• What happens when exporting a simple object?

If not solved after looking into the above, Post the FreeCAD file, I’ll look at it

Those two files are WRL, which is a type intended for appearance rather than mechanical accuracy. It used to be common for them to be scaled by 1:2.54 thanks to the use of 0.1" units

2 Likes

Yes FreeCAD is already setup in mm. I don’t use Inches, since I’m in EU
i exported form PartDesign, at that time it was the only WB I was able to use (I created the parts a couple of years ago)
I exported the Last Item, since I didn’t know how to use any other WB. However the part is very easy, being a double inductor contained into a rectangle extruded and 4 pins (4 cylinders). That’s it

I will try to get the part again and to re-export checking the first point you highlighted especially the “legacy” since i didn’t pay attention on this, having, at that time, not confidence at all with FreeCAD

@BlackCoffee @davidsrsb thank you guys. Following your indications, I was able to export it correctly

I checked the old project in FreeCAD. I’ve remade the parts, and exported it properly.
Re-imported on KiCAD just repositioned, and exported the PCB: fantastic. now it is as it should be.

Thank you so much

2 Likes