SOLVED - Noob needs help importing DC-DC.lib

Brand new to KiCad.
As my first attempt I’m wanting to use the DC-DC library but I’m having a great deal of trouble importing it.

It always says that the file is NOT an Eeschema file.

hat am I doing wrong?


Assuming your KiCad setup is correct, you should be able to go into Preferences->Component Libraries then click the Add button, and then select the dc-dc.lib.

Thanks Bob,
I WISH it was that easy :slight_smile:

When I do exactly that it keeps saying “File is NOT a Eeschema file”!

Where did you get the library from?

What kicad version do you have?

Have you added the location of the library to the search path? (bottom half of the dialog shown in the screenshot by @bobc)

Hi Rene,
I got the file directly from the KiCad website library. It was last updated 9 days ago. That made me think it would work with no issues. It even has the word Eeschema in the file itself so I have no clue

Adding the path did not help. It seems to be able to find the file. It simply is rejecting it.

Thanks to everyone who assisted.

The problem turned out to be that I had not saved the LIB files in RAW format. I had saved them in HTML format by saving them directly from the HTML page and so all the HTML formatting was included.

As soon as I realized that and copied the files in RAW format and saved that to a text file it worked perfectly.

Thanks again for your help!


One more reason for @SchrodingersGat to go ahead with his github re-implementation :wink: