[Solved] Multiple ERC errors for simple schematic

Pins 1 and 3 are set as power input, pin 2 is output. I’m trying to wire them to a generic connector, and I do not understand what the issues are.

“Pin connected to some other pins but no pin to driver it”
“Different net assigned to a shared pin in another unit of the same component”

The error type 3 is easy. Your GND net doesn’t have a power output pin anywhere on it. You need a power flag (PWR_FLAG) on that net as well. More details can be found at this FAQ item:

As to the error type 12… I don’t think that I’ve seen that one before. Hopefully someone else may have an answer to that one. Since the U1 isn’t U1A, I’m not sure how “another unit of the same component” applies here…

BTW, there are several versions of KiCAD currently being used out in the wild, each with their own quirks. Please inform us which version you are using so we know which quirks apply. :wink:

1 Like

Good point. 5.0 Windows release

There is a problem with the symbol. Where did you get it?

It’s straight from the library, I just named it for the sensor I’m going to use.


Is it possible you have another symbol in the same schematic that uses the U1A reference? Maybe kicad is just confused because it finds the same reference twice. You could run reannotation with “delete old annotation” selected.

I wish it was that easy. That screenshot is the entire schematic though.

Off Topic: Thanx for fixing my link, @Rene_Poschl . I didn’t notice that I had linked to one of the replies instead of the top of the thread.

Are you sure? The one I have is different.


If you post a copy of the data for the symbol you are using, maybe we can help.

I suspect there is a hidden pin that is getting accidentally connected. Hidden pins are evil…

Ok, now I am 99% sure, someone has taken the 4 pin symbol and adapted it for the 3 pin DRV503 by changing pin 4 to GND but not deleting pin 3 NC. Replicating these steps I get the same error:

Like I said, hidden pins are evil !


I didn’t think anything of that when I changed the pin number. As soon as I edited to delete that hidden pin, it works fine. Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.