(Solved) More 7.0.1 woes installing on Ubuntu 20.04. What does this mean?

Every time I open a schematic, I get this cryptic message. What does it mean?
(my Python install is 3.8.1, BTW).

What distribution are you using? There was a configuration issue in v7.0.0 that could lead to this kind of message, but it got fixed in 7.0.1.

I built 7.0.1 myself and the message doesn’t appear anymore indeed. But in your case, it looks like the wxWidgets version and wxPython versions on your OS do not match - or rather that wxPython hasn’t been updated yet to wxWidgets 3.2.x.

Lubuntu 20.04.5, KiCAD 7.0.1

I’ve now surfed around trying to find a way to install wxwidgets 3.2.1.
Sorry, but no cigar.

I was kind of becoming friends with 7.0.1, but this straw broke the camel’s back. 7.0 is too immature and non-production ready.
If it needs wxwidgets 3.2.1, then include it in the install! Why do I have to run around searching for certain versions of software that I don’t even use? And to wit: software that’s not available for download? Not even on the KiCAD launchpad page (3.0 is, BTW).

It’s finally back to 6.0.11 until this mess gets sorted out.

The Ubuntu PPA for kicad-7.0-releases does include packages for wxwidgets 3.2, see the bottom of this page:

Not sure why your package manager didn’t pick them up. Also strange as lots of other people have 7.0 working on Ubuntu or Mint.

Sorry, I’m not on Ubuntu so I can’t trace any further.

That’s a non-clickable index of “something”, but certainly not a way to install “wxwidgets 3.2.1” which apparently is needed for 7.0.1.
This launchpad page is more to the point:

No mention of 3.2.1, right? And other Internet searches bring no joy either.

But it’s OK, my trusty system restore (Timeshift, has never let me down) has already brought back my 6.0.11.
I’ll wait until 7.0.99 comes out, then it may be an option.

PS: this page is even worse:

That’s an info page I posted, not a download page so those are not links and you are not meant to install by downloading package by package anyway. The PPA is added following the instructions on kicad.org and installs are done through the package manager.

Maybe other, successful, Ubuntu users can help you. Otherwise maybe the universe does hate you.

Don’t be condescending, please. I can assure you that I know what I’m doing in Linux.
I just edited my post above as well.
I’ve found no PPA to install wxwidgets 3.2.1, except a couple of experimental/suspect ones.
If you have better info, I’m all ears! A link to a trustworthy PPA would be pure gold.

Sorry somebody else with Ubuntu will have to take over the baton.

All good, thanks for taking interest and effort.

Yep, in any case, I think the problem has to be dealt with with Ubuntu’s kicad package maintainer.

It’s not strictly a KiCad issue, although Ubuntu is officially supported by KiCad, so…

Looks at the minimum like the package doesn’t automatically pull the right dependencies.
Now I have no experience with Ubuntu’s package manager, I’m a long time user of Arch, so I don’t know how common those dependency issues would be.

My guess is that the required version of wxPython is just not available for a 3 year old base install

When moving from 6.0 to 7.0, do

apt upgrade

to update wxpython4.0 package and other dependencies.

Mint has wxwidgets 3.2.1. That arrived in a Mint update a few days after Kicad 7 was released.
I believe it also arrived on Ubuntu at around the same time.

wxwidgets 3.2.1 just came wandering in to my computer all by itself. It did introduce itself, but I didn’t have to go and find it.

Was needed for plugins in 7.0.0

Application: KiCad x86_64 on x86_64

Version: 7.0.1-unknown-202303111720~9e1fd16329~ubuntu22.04.1, release build

wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 6.0.0
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.13

Platform: Linux Mint 21, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Mar 11 2023 17:20:02
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.87.0
ngspice: 38
Compiler: GCC 11.3.0 with C++ ABI 1016

Build settings:

Look, there is no shame in not knowing something but you clearly are not as good with linux package management as you think. The ppa link shows that kicad’s repository has everything needed for kicad, including correct wxwidgets and wxpython packages. You don’t have to go searching for downloads of libs anywhere. If you followed instructions on installation page correctly you should not see the issue you are experiencing.
To help you debug, first do sudo apt-get update && sudo apt-get upgrade, see if you still experience the issue.
If you do, then post versions of python3-wxgtk4.0 and libwxgtk3.2-1 packages.

1 Like

you do not need a different PPA, the kicad-7.0-stable PPA has wxWidgets as was already pointed out.