[Solved] Model Doesn't show in 3D render, but is viewed fine on propreties

I have a specific component that isn’t shown on the 3D render. But when I go to the footprint 3d Properties, it isn’t shown without an issue. I have tried re-selecting it, and also using another model instead., but it’s not shown either.

I attach some screenshots below:

(Uploading 2nd image as a reply, due to new user limitation)

There are some buttons at the top of the 3D viewer that turn on/off certain parts. Maybe one of these is clicked?



haha, that was it, (It is marked as though hole due to the inner pads ??)
Would never cross my mind.

Thank You

It’s not due to the pads, there is a drop down in the footprint edit box that select which “layer” the part is associated with:


SnapEDA or UltraLibrarian often put these on the wrong “layer”.

I actually wish that you could add other “layers” here, so that you can turn on/off certain groups of parts.

1 Like

Oh, I see. Good to know.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.