(solved) Missing Button (save/select) in Title Bar on XFCE with switched off CSD

Hi there,
I’m new to this forum, don’t know if I’m right here with my question …

I use KiCAD 5.1.10 on an Arch Linux using XFCE 4.16. Due to the ugly CSD (Client Side Decorations) I switched it off by
xfconf-query -c xsettings -p /Gtk/DialogsUseHeader -s false

This switches all applications back to server based decorations an everything looks quite good … but without KiCAD! In KiCAD I now miss entry buttons in the menu bar or header bar, like save- or open-buttons (the ones right in the top bar).

Is there any solution to this issue or why is it so? Because in any case KiCAD get’s the server decorations with switched on or off client side decorations.

I hope there will be a solution otherwise I have to grade down XFCE …

cheers, Ingolf

Hi, I found something to tweak:
In XFCE there is a settings menu where you can switch on/off some Gtk options: xsettings / Gtk / DialogsUseHeader
I switched this off so the Buttons are not in the header bar anymore but on the bottom of the dialog windows …

… I would say I’m saved for the moment. Should I mark this thread as solved?

cheers Ingolf

1 Like