[SOLVED] KitKit plugin issue: installed but "not present"

I tried to install this KitKit plugin

Pic:1

and I had to install the full kit as asked here

Pic:2

I followed the instructions here, keeping in mind, my KiCAD installation in not n C:\ but on K:\kicad

Pic:3

Because there where warnings about the package, indicating to add the directory into the PATH of Windows, I did it:

Pic:4

BUT
I still get the Warning windows of Pic:2 AND when I digit kitkit --help (suggested in Pic:3) I don’t get anything:

image

you typed kitkit instead of kikit

1 Like

OMG I’m dumb :sweat_smile: I continued to type that never realizing I had too many Ts :slight_smile:
However, kiCAD not working with.
Typing correctly “kikit” I have

But when I open kiCAD I get this:

I’ll piggyback on this topic rather than creating a new one as I have a somewhat related query:

I would like to experiment with KiKit, with Kicad 6 on Fedora 35 - at present I can only install Kicad 6 as a Flatpak (it won’t be included in the standard repos until Fedora 36, which is months away). Apparently the Flatpak-ed instance of Python doesn’t include pip so adding the KiKit backend has me stumped. I guess that it sort of goes against the spirit of Flatpaks to go in and modify/add things that could potentially break the Flatpak, (though adding things from the plugin manager works fine) but there must be a way around this? I would really like to avoid solutions that involve using a different operating system or using an older version of Kicad.

I’ve had a search around but possibly my search terms are not exactly right as I haven’t found anything that details interacting with the content of a Flatpak in this way…

Hi, I guess you run MacOS, right? Unfortunately, there are some problems with the GUI plugin in MacOS. I am not a mac user so I cannot help and investigate properly, but there a few users trying to find out what’s wrong. Read the relevant issue: https://github.com/yaqwsx/KiKit/issues/252

I am sorry for not able to help.

No, I’m running Windows 11

Did you follow the instructions and installed KiKit from withing “KiCAD command prompt”? KiCAD brings its Python a Pip so if you install it with any other Python, KiCAD won’t see it. And you cannot use the CLI as KiKit won’t see KiCAD.

Follow: https://github.com/yaqwsx/KiKit/blob/master/doc/installation.md

On my system (Ubuntu 21.10) the “OK” doesn’t do anything

Same here on Windows 10

1 Like

I did said this in my topic as you can see. I did it. Or I was not opening the thread

I have to repeat I see:

Even on Windows 11. the OK is useless.

SOLUTION

the author helped me and I report here the solution in case of somebody else got the same issue:

I believe that you used “Windows Command Prompt” instead of “KiCAD Command Prompt”. They are two different things - see them side-by-side”:

prompt

1 Like

IMPORTANT

i updated to 6.0.1 and I got again:

So; pay attention to this will occur again

Same here. Just installed 6.01. Then I installed Kikit via the plugin manager and then used the Kicad command line to setup kikit. However I am still getting the “kikit is not installed” dialog box. How do I fix this? Thanks.

I installed the backend with 6.0.0 command prompt (“pip install kikit”), then updated KiCad to 6.0.1 and installed the GUI with the PCM. It works.

The backend was installed to C:\Users<username>\Documents\KiCad\6.0\3rdparty\Python39\site-packages. The GUI to C:\Users<username>\Documents\KiCad\6.0\3rdparty\plugins\com_github_yaqwsx_kikit.

I can also use the KiCad PCB Editor’s Tools → Scripting Console to import kikit and kikit.plugin and run kikit.plugin.importAllPlugins().

1 Like