[SOLVED] KiCAD StepUp clearence between zones deformed

Hello,

I noticed today that when importing the copper of my board in KSU, the borders are not correct and somehow fused together and I am not sure why, it could be an option that I have not set in FreeCAD, however, I am not sure what should I change.

@maui do you have any idea what could it be? To be clear, I mostly use KSU for documentation/dimension purposes, as such this is not a “real” problem for me so far. Thanks again for this extremely helpful plugin!

FreeCAD:

KiCAD:

Gerbv:

Application: Pcbnew
Version: (5.1.8)-1, release build
Libraries:
    wxWidgets 3.0.5
    libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.73.0
    OpenCASCADE Community Edition: 6.9.1
    Curl: 7.71.0
    Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
    USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_PYTHON3=OFF
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON
    KICAD_USE_OCC=OFF
    KICAD_SPICE=ON

FreeCAD and KSU Versions:

12:49:47  PoM not present
12:49:47  using 'Part' container and 'Links'
12:49:47  FC Version 019-23323
12:49:47  Asm3 WB present
12:49:47  kicad StepUp version 9.7.3.2

@der.ule
it would be probably because you have set a clearance on your zones… I don’t think that zones get built using that parameter…
'cause I use fcad_pcb library to load the traces, you may open an issue @realthunder repo https://github.com/realthunder/fcad_pcb

Are you sure about your KiCad version? The screenshot looks like it’s impossible to get that kind of visual appearance in v5.1. It looks like 5.99.

Maui, does KSU read 5.99 files? If yes, and the file is from 5.99, I have a theory about the problem. In 5.1 zones had outline segments which had the same width as the minimum width, if I remember correctly. In 5.99 it’s possible to fill zones without those. Is it possible that KSU always adds those outline segments to zones?

@maui thanks a bunch for the info, I have tried to replicate the problem with a smaller board and a couple of zones but unsuccessfully :S

@eelik I am sure about my kicad version, the look of my screenshot is because I’ve been setting the style of kicad directly in the configuration file for a while.

EDIT: I raised the issue at GitHub

@der.ule
do you have a kicad_pcb file to test? I would like to have a look…

Yeah sure! As I said I could not reproduced with a test board, but I could share with you the original board charger.zip (57.3 KB)

Thanks!

ok, it is as I supposed: fcad_pcb gets the fill zone geometry without taking count of clearance…
we would need to post an issu @realthunder gh repo…
at the same time an escamotage is to export the traces as DXF and import those in FC using the KSU tool to import SilkScreen (the button with 'T’ext)
The result will be correct, but less nice, because it doesn’t distinguish between Masked Cu and doesn’t apply drill holes… It can be tweaked with a bit of work to add also drills


lipo_charger-w-traces-FC-dxf-files.zip

Thanks a lot maui! I raised the issue in GitHub already, lets see if realthunder has any ideas on what to do next.

The workaround that you mention is more than enough for my needs, great!

Well, once again I am in awe at the people in the open source community (specially KiCAD and FreeCAD), @realthunder fixed the overnight and it is working as expected in the lastest fcab_pcb version! Just amazing!

4 Likes

@der.ule it should now fixed also in KSU :smiley:
please update the wb

4 Likes

Flawless !! Thanks a lot for your help and for this fantastic plugin !!

10:30:53  PoM not present
10:30:53  using 'Part' container and 'Links'
10:30:53  FC Version 019-23323
10:30:53  Asm3 WB present
10:30:53  kicad StepUp version 9.7.3.2
1 Like

Small detail that I just noticed: FreeCAD prompted me to update the workbench, because I was one version behind, the results speaks for itself that it worked. However the KSU version string is the same:

I just updated the kicad_parser version for traces, but it is correct to align also ksu version… now it should be fine

2 Likes

Yes it is! Sorry if I am taking too much of your time. :slight_smile:

11:03:46  PoM not present
11:03:46  using 'Part' container and 'Links'
11:03:46  FC Version 019-23323
11:03:46  Asm3 WB present
11:03:46  kicad StepUp version 9.7.3.3
1 Like