[SOLVED]Kicad 6.0.9 complains about symbol library versions and requests KiCad version 20220914 OR LATER

Kicad 6.0.9 complains about symbol library versions and requests a KiCad version 20220914 OR LATER.
Ok, 6.0.9 is the latest version and for sure newer than 20220914.

Here is the header (first) line:
(kicad_symbol_lib (version 20220914) (generator kicad_symbol_editor)

Fun fact: when I change that to, say,
(kicad_symbol_lib (version 20210914) (generator kicad_symbol_editor)

the library is digested.

What’s going on here?

When do you get that error message?

I just started KiCad V6.0.9, but it starts normally.

My everyday version is 6.99.
This said I had no libraries loaded in 6.0.9.
It happens when loading the libraries in the library manager

What’s stunning me is 2022xxxx is a problem, 2021xxxx (one year older) is NOT. Or do I misinterpret the header?

Hi Paulvdh,

I can confirm what Straubm noticed when I was using kicad-6.0.9 for the first time.

In fact I built kicad-6.0.8 (from scratch) and was working for almost 3 days constantly
to acquantain myself (I come from kicad-5.99 and hence upgraded to kicad-6.0.8).
I was told that kicad-6.0.9 was lying around the corner so I decided to upgrade from
kicad-6.0.8.

The phenomenon will show up when the schematic has been checked on violation
errors (which as result is described in issue 12814), when going to the
pcb design. The message popped up describing what Straubm was seeing.
I tried to return to kicad-6.0.8 in order to use the same project but unfortunately I
got the same result and the damage could not be undone.

I really had to restore my project backup (built with kicad-5.99) and tried again with
kicad-6.0.8 to see if the project was messed up again. Fortunately no violation errors
were detected after making some improvements with kicad-6.0.8. While at kicad-6.0.8
I started up the pcb design and that went OK as well. I also checked that another
project is doing OK again with kicad-6.0.8 (both schematic diagram and pcb design).

Then again started up kicad-6.0.9 with the first project. What ever I tried to do to
reproduce the phenomenon and damage it did not show up even switching twice from
kicad-6.0.9 to kicad-6.0.8 and back.
I could not reproduce the phenomenon and the damage afterwards.

I suspect that there are some leftovers in the kicad-6.0.8 project itself which were
introduced after a lot of work and/or improvements in the project. But A very
weird experience …

Br,

Armand

I had no project loaded at all…

I unistalled/deleted everything KiCad 6.0 and reinstalled 6.0.9 with standard settings and empty library tables. Same story.

I’ running 6.99 in parallel, but that was never a problem. Btw, 6.99 has no problem with the libraries (I checked that by removing and re-adding all libraries).

This is the most recent nightly symbol library format version. The experience you describe is what would happen if you saved a symbol library using a nightly and then tried to open it in 6.0.9

The latest stable (6.0) library version is 20211014, which is later than 20210914 and so is accepted.

Ok, that explains it, thx. No harm done as I work with 6.99 and it’s hobby only anyways.
Unfortunately I always forget to change to 6.0.x when changing something in the libraries.
I suppose V7 will sync me again.

Btw, a quick check showed the libraries with the changed header seem to work. But I won’t rely on that.