SOLVED. Just upgraded to 6.0.2 - My 5.1 schematics are no longer visible. Just a gray sheet

Can it get any better than this? [/sarcasm]
I’ve just lost all my work due to an upgrade.

Now, luckily I’m a smart guy, and can restore my system to 5.1

BTW, I hate the new opening “splash screen”… and it can’t be disabled. Is this really the result of two years’ work on 5.99? And you’re already talking about 6.99? Wow.

Thumbs down all the way.

If your client or employer requires KiCad you can say you are forced to use it, otherwise, you can choose not to use it.

I can understand how people get very frustrated because of software. But spreading sarcasm here doesn’t help you, and makes others here angry, too.

What splash screen? KiCad opens directly to the project window.

“Schematics no longer visible.” Maybe it would help if you would share a screenshot. We might be able to tell if schematic content is really lost, or if it’s maybe a rendering problem which can be fixed by changing settings.

That doesn’t qualify as good, entertaining sarcasm, either. It’s just the KiCad project development model. Pretty normal stuff: a new version is released, development continues. The new version gets bugfixes.


My sarcasm did not arrive well. I accept that.
But then look at this:
1: a 5.1 .sch file opened in 6.0.2:

2: another 5.1 schematic opened, saved and reopened in 6.0.2:

The gray background is relaxing, of course, but not very productive.

OS: Lubuntu 20.04

Can you start a new project and draw something visible there?

You have the grid on, so at least the dots should be visible, and also the drawing sheet and page limits unless you have changed the settings. I guess this is a rendering problem. What happens if you switch between Accelerated and Fallback graphics in Preferences → Schematic Editor → Display Options → Rendering Engine?

Lubuntu seems to use Wayland. See Known System Related Issues | KiCad EDA. Maybe that’s the cause?

Sorry but you’re way off.
The grid is on, yes, but it’s not visible at any zoom.
My display is 1440 x 900 (laptop), I hope that KiCAD can cope with that.

No, there’s an internal problem with 6.0 opening 5.1 files. And it’s serious.

My schematics contain parts from custom libraries, until now stored in:
The schematic opened as a gray screen.
I copied the libraries to:
Gray screen again.

I’ll now reinstall 5.1 from my backup, this is intolerable.

You have not provided any evidence of this so far. Try opening a demo project that ships with 6.0. It’s guaranteed to be valid schematic file, see if it renders.

If it does, then there may be some issue with conversion of 5.1 files. But it’s much more likely that it will also show you grey screen which means the issue is rendering and you should follow eelik’s advice to try fallback graphics.


I second @qu1ck. Certain combinations of Linux distributions and graphics cards have issues with OpenGL under Wayland.

@ML9104 I can check if your file opens correctly on v6.0.2. You can PM it to me.


I would love to see a screenshot of the “splash screen”
My W10 6.0.x jumps straight to the project viewer with tool selector just like KiCad always has done

No demos installed.
But the Wayland/rendering hypothesis is way off. First, because the screen renders perfectly as you see from my screenshots. Second, because I’m running 20.04 LTS which does NOT use Wayland.

I have a different suspicion:

6.0 has a problem with UNIX/Linux file access permissions.
My $HOME directories all have rwx-rx— permissions. This is not unusual on multi-user -systems.
Probably 6.0 tries to access the files as “other”, which is not permitted. Or 6.0 tries to write to my files with “group” or “other” permissions, which is also not allowed.
In 5.1.12 everything works 100%.

This is not how Linux/Unix permissions work. Unless you invoked KiCad as superuser (root), say with sudo, which is an abnormal thing to do and would usually ask you for a password, the kicad process runs as you. You can verify this by running ps au while kicad is running and looking at the process owner in the left column.

This is true of all applications, not just KiCad.

1 Like

Think the rendering issue affects only the drawing area not the icons/ menus / layer control etc.

1 Like

We’re on the same page here, and I know exactly how the permissions work.
But that doesn’t mean that KiCAD will not attempt an access that’s unallowed. You have no idea what the programmers have done. You seem to assume that 6.0 is perfect.
Why should it be impossible for 6.0 running under the current user to make a file access attempt with no user priviledge, eg, “other”?

Once again: Lubuntu 20.04 LTS does NOT use Wayland!

Because… that’s not how that works. Even if we inserted code to try to change what user we appear as to the filesystem, that code would not succeed unless you ran KiCad as the superuser.

Running a process as a different account is a privileged operation, and would be a huge security hole if it could be done without permission, such as a password or a setuid bit.

From what you have written, you are not on the same page as all the people who understand Linux/Unix permissions.

I just tried again and got this after installing the PPA and updating the cache:

You seem to assume something else is perfect.

Wayland isn’t the only thing which may cause rendering problems. As was said, OpenGL rendering may be affected even though everything else is fine, and usually those problems come exactly as you describe: empty rectangle of some color.

What I find weird is that you still haven’t told us if a v6 project can be seen. This is very simple: if you can see the design even with one project, then rendering is not the problem and we can continue with something else. If there really is a problem in opening v5 project, the issue is important and the reason should be found so that it can be fixed.

Where’s the weird part? 6.0 isn’t working, so what should I show? Tlak about chicken-and-egg…

Look, they gave you a specific instruction (open one of the sample files included with kicad and see what happens) and you haven’t done it.

You also need to stop being so grumpy to people who are trying to help you.