[SOLVED] Issues with Debian 12 and KiCad 7.0.6

I’m running Debian 12 on my main laptop. To install KiCad I cloned the repository and built tag 7.0.6 (the version info is at the end of this post). When I tried running it the “Configure Global Symbol Library Table” dialog came up with the “Copy default global symbol library table (recommended)” grayed out. Should KiCad built from source have this option available? How do I make this available?


Application: KiCad x86_64 on x86_64

Version: 7.0.6, release build

	wxWidgets 3.2.2
	FreeType 2.12.1
	HarfBuzz 6.0.0
	FontConfig 2.14.1
	libcurl/7.88.1 GnuTLS/3.7.9 zlib/1.2.13 brotli/1.0.9 zstd/1.5.4 libidn2/2.3.3 libpsl/0.21.2 (+libidn2/2.3.3) libssh2/1.10.0 nghttp2/1.52.0 librtmp/2.3

Platform: Debian GNU/Linux 12 (bookworm), 64 bit, Little endian, wxGTK, gnome, wayland

Build Info:
	Date: Aug  9 2023 17:43:05
	wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.6.3
	Curl: 7.88.1
	ngspice: 39
	Compiler: GCC 12.2.0 with C++ ABI 1017

Build settings:

Never built KiCAD myself, but recall this message from some point.
Ignore it and run KiCAD, when the symbol list is missing, KiCAD will build a new one from scratch (by scanning the default libraries).
It’s located at ~/.config/kicad/7.0/sym-lib-table

Just try it.

That option is greyed out when you don’t install the libraries to the proper locations

Since you built from scratch, you must also check out all the libraries and run the cmake install on them

I cloned the libraries and installed them, that fixed the problem. I also had to run ldconfig to get the libraries (.so) recognized.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.