[SOLVED in 7.0.1] Fusion 360 export to KiCad 7 and broken colors/opacity

I created a simple 3D model in Fusion 360, assigned two materias as Appearance for it: Gold Polished and Black Plastic (Matte). I exported the model as a Step file. It works fine but the colors are broken. If I have the Opacity at 100 In Kicad Footprint editor, it looks like this:

If if set opacity to 99/100, it looks like this:

Any ideas what did I do wrong? It should look kinda like this:

Ie. just solid plastic and golden pins. No transparency.

Ok, this might be a known issue in KiCad 7. Both of these fixes address Step file colors:

So, I hope this will be fixed in 7.0.1. I’ll report back here once it is available.

This won’t be fixed by those commits.

The problem here is it seems Fusion 360 is exporting the STEP models with opacity set pretty low on the black color. STEP files don’t actually have materials so while inside Fusion 360, “Black Plastic (Matte)” exists and looks good, Fusion 360 has to close its eyes and pick something as a singular RGBA color for the STEP file. And somehow that means making it transparent.

There is a opacity ordering issue in the 3d viewer currently but the fix for that is only in the 7.99 currently.

1 Like

Ok, thanks for the reply. I’ll then need to figure out how to just give regular working colors to bodies in Fusion 360 to get rid of these issues. Or just manually edit the Step file to fix this (ie. remove the transparency).

Just try a different material, maybe there’s a “Black Epoxy” material or something (chip bodies are epoxy instead of plastic anyway)?

would you mind to post the model in STEP format?

Sure! Here is the file (still in WIP). It should have 2 materials assigned, black and gold. But I see only gray if the KiCad 7.0.0 opacity is 100 and is see transparent black if the opacity is anything below 100.

SHT40.step (53.7 KB)

That didn’t seem to have any kind of effect. Fusion 360 seems to have only a couple of materias with the word “black” in it.

I’ve spent a good bit of time with STEP colors in conjunction with the Coloring App I’m making as a resource tool for Kicad/other parts.
It’s almost finished (actually the Mac version is done and posted but, Windows and Linux are in process - in fact, I took a break from coding them to post this…)

I won’t comment on Fusion and what it does with STEP file colors except to say that, though not yet fully baked for STEP files that I don’t create specifically for my app, it was easy to tweak your part with my app…

screenshot below shows original file with my preped tweaks prior to coloring with my app. Then, the tweaked colors - the preped tweak contained only items for the four selections so, other color settings are not valid - thus, only the Yellow items are changed.
As far as Alpha/transparancy… that’s another story.

1 Like

the file seems fine in CAD Assistant and FreeCAD,
so it seems an issue on KiCAD side

1 Like

Thanks for testing this! I think it I’ll file this issue to KiCad GitLab so they can take a look at it.

Hey BlackCoffee, I’m looking forward to the linux version of your step-colorizer-retro-turboencabulator!

I filed an issue. Let’s see how it goes.

btw it seems to be correctly displayed on kv7 testing

Application: KiCad PCB Editor x64 on x64

Version: (7.0.0-147-gd311915f9d), release build
1 Like

Ok, then it is possible that the commits I listed above actually fixed the issue. For some reason @marekr said they were not relevant. But at least both issues mentioned that the models are gray and don’t have the correct color.

Also, manually inspecting the step file looked like there is no opacity/alpha/transparency values anywhere. So the issue related to me setting the opacity to 99 might not be related to the main issue here.

All issues were indeed fixed by the commits I listed. In 7.0.1 all looks correct:

Also closed the GitLab issue.