[Solved] How to link the pads with each other?


#1

Hi all,

I would like to know how do I connect the pads together?

In the image, I would like to connect pad 1, 2 and 3 together but Kicad keep showing me errType 4 track near pad. Is it because the pad can’t cross the path which is why it keep showing me error?

Is there a better way to link the pads together? Or I have the design rules set in the wrong setting?

Any feedback is much appreciated.

Thanks in advance.


#2

Are these 3 pins connected in the schematic?
If no then kicad will rightly not allow them to be connected in pcb_new.


If they are then check your drc settings and also the settings under the dimension dialog.

Maybe also use the highlight net tool to check if pcb_new thinks these pads should be connected.
If not all 3 pins get highlighed at once with this tool then your pcb and schematic might be out of sync. You need to export the netlist from eeschema and import it into pcb_new everytime you make a change in the schematic.

If you want the zone to connect to them then remember that zones have their own clearance and minimum width settings.


#3

The resolution is low, but it appears pads 1,2,3 are on different nets, so they should not be connected.(For a MOSFET it seems unlikely you would connect those 3 pins). I can’t explain why there is an air-wire there, maybe a bug/graphic artifact.

The schematic shows what should be connected, which you can see but we can’t…


#4

This is the MOSFET I going to use, pins 1, 2 & 3 are source pin so I thought linking them together would be the same no?

Do I have to change the symbol of the MOSFET on the schematic in order to have the pads connected?


#5

Yes, that’s ok. But there seems to be something wrong with your netlist, it shows, 1,2,3 on separate pins and 4 and 5 not connected.

I bet that the symbol you have used in the schematic is for a 3 pin mosfet, but the footprint you are using is for 5 pin. You need to have the symbol match the footprint.


#6

Ok, I’ll go take a look. Thanks @bobc and @Rene_Poschl


#7

May I ask would this be the symbol to match the footprint?


#8

The symbol looks good.

But you might want to make a derivative of it in your personal libs

  • Name it after the component you want to use (= use the manufacturer part number as the symbol name)
  • Set the footprint field to point to the correct footprint (Make sure the footprint you selected fits the requirements of this part. Compare it against the drawings)
  • Fill out the description, tag and datasheet stuff to fit your component.

If you do something, to it properly. Future you will thank you.


Maybe also read up on what symbols and footprints mean in kicad


#9

@Rene_Poschl I’m curious if I could just change the component properties and assign the footprint that match the symbol?

Or do I make another symbol and assign to the footprint?

Never mind what I mentioned.

I understand what you mean.


#10

There are a lot of things you could do. Following the advice of @Rene_Poschl is the smartest of those things. He helps maintain the libraries so this is his area of expertise in the Kicad world. :wink: Saving this off in your own personal library so it doesn’t get changed in the future is the first step. You rename it so it doesn’t conflict. Change what you want after that. :smiley:


#11

Yea I noticed it after when I tried that and realize that what @Rene_Poschl said was a better option. :relaxed:


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.