[Solved] How to crosshatch on paste layer without DRC unconnected items error?

Hi,
Using KiCad 5.1.6, when I modified a footprint pad to add crosshatching on the paste layer, I now get a number of DRC “Unconnected items” errors between the paste and copper layer in my layout. I did the cross hatching by unchecking the paste layer on the pad and adding additional pads on top to form the crosshatching on the paste layer.

Any ideas what could be wrong? For good measure, on the paste-layer pads I also tried clearing out the pad number field and setting the “pad connection” field to None, but that didn’t help.

Here’s the copper layer:

And the paste layer:

Thanks for any suggestions.
Josh

Set the paste layer pad type to aperture. It takes off the copper layers.

Tutorial: How to make a footprint (From scratch)? section “the exposed pad”

Good link, thanks.
It turns out that I think any pad that is on just the paste layer can not have a non-empty pad number or the DRC complains because it isn’t connected on that layer.

And it looks like setting pad type to aperture is equivalent to setting the “copper” pull down to “None”. In fact, if I set the type to aperture and click ok and reopen the properties window, it shows just as SMD, without the aperture selected.