[SOLVED] HotKeys doesn't work on nightly footprint editor


#1

Hi,

I’m using the Ubuntu PPA nightly, i’m trying to edit a footprint i started yesterday (saturday March 4), but today the hotkeys doesn’t work, none of them. I haven’t use KiCAD in some weeks so maybe i’m missing something.

Can somebody confirm this before filling a bug report?

Thanks in advance
Carlos

KiCAD Version:

Application: kicad
Version: no-vcs-found-f181961~58~ubuntu16.04.1, release build
Libraries: wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-64-generic x86_64, 64 bit, Little endian, wxGTK

  • Build Info -
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.58.0
    Curl: 7.47.0
    KiCad - Compiler: GCC 5.4.0 with C++ ABI 1009
    Settings: USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON

#2

Oooooooooopsie.

My fault.

Fixed a bit over an hour ago.

Next nightly should be good.


#3

Cool, thanks for the quick answer :smiley: .