[SOLVED] GND pins not connecting to GND copper pour

Hi all,
I have a design I created in v5.4.1 and brought it up in V7.0 to create new Gerbers to have fabricated. Upon running DRC I found some errors and warnings I needed to correct. Upon updating the fills, I found that the GND pins are no longer being connected to the GND plane (back side copper pour) with spokes. Both the copper pour and pads are assigned to net GND.
The strange thing is that the +3V3 pins are being connected when the fills are updated. Upon checking the Pad Properties → Clearance Overrides and Settings, the settings are the same for the +3V3 and GND pads.
I’ve tried placing some GND vias and running a trace to these pins, which is electrically correct, but I get “Warning: via is not connected or connected on only one layer”. I can ignore these in the settings, but I dislike doing that.
I’m at a loss here. Any help would be greatly appreciated.

Thanks, Perry

If you are able to ZIP up your project and post it that would probably help. If not some images of the area in question, or an example area might help . . .

Hi Raptor,
Thank you. I was able to get the errors corrected by creating a new netlist and updating the layout from the netlist. The +3V3 and GND pins are all being connected to the copper pours correctly now.
Best regards, Perry


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.