[SOLVED] GerbView zoom is not working

I was trying to use GerbView to check a gerber file copper layer. When I try to zoom in to view detial, the zoom is not working. I tried using the mouse scroll wheel to zoom, the +/- buttons on the tool bar and the zoom level drop down. Interestingly, when I choose the zoom drop down, the drop down immediately switches back to “Zoom Auto”. Zoom to selection does not work either. I am using KiCAD 5.1.7 on Win 10. Is it the same for anyone else? The closest that I can zoom is about the page level.

After playing with it a little more, I am realizing that part of the problem is that the scroll bars are going way off to the right and bottom of the drawing space when I use the scroll wheel or the “Zoom to selection” tool.

I have checked for any reported issues for this, but did not see anyone else with the same issue. Which I would be surprised if I was the first to discover this with it being out a month at this point.

Hi,

I am having a similar issue, I assumed it was a problem with the files I was trying to view but have tried again tonight with some other files and am having the same issue, I’m on version 5.1.8

When I open the files I see the PCB layout, any attempt to zoom in using the zoom in icon, F1 or the mouse scroll wheel and the layout goes off screen, I can recover it using Zoom to Fit.

It would be nice if a couple more people could confirm (or deny) this issue, then it can be reported as a bug if needed.

Zoom working fine as expected in v5.1.8 either with the mouse wheel or F1 and F2. I’m using Ubuntu ppa.

Already fixed in the 5.1.x Testing nightly builds

This one was a legacy canvas error

1 Like

Thanks for the link! In looking over that issue, I saw a work around until the next version is out: https://gitlab.com/kicad/code/kicad/-/issues/6326#note_443890379

Basically: click “Preferences” and then choose “Modern Toolset”, then it works fine for me.

The only serious reason to use the legacy toolset is a broken graphics card OpenGL driver

Do you know what the default toolset is ? I can’t remember having ever changed it, I have changed to Modern Toolset (Accelerated) and the zoom is working great for me too.

It SHOULD be Modern as Legacy will be dropped at some point
The emulation one will be kept for people with broken graphics drivers.