(Solved) Fill zone not respecting net class clearance

Hi all,
I have troble to get a fill zone to respect the netclass clearance.

Default netclasse has clearance of 0.1 mm
VBAT netclass has clearance of 0.5 mm

If I define a zone attached to GND I would expect the fill zone to respect the defined netclass.
Even if I give the fill zone a clearance of 0.5 it doesn’t respect that, it always fill until it is 0.1 mm from an other net.
Fill zone priority = 0

Any thoughts?

Application: KiCad PCB Editor x86_64 on x86_64

Version: 7.0.3, release build

wxWidgets 3.2.2
FreeType 2.13.0
HarfBuzz 7.3.0
FontConfig 2.14.2
libcurl/8.1.2 OpenSSL/3.0.8 zlib/1.2.13 brotli/1.0.9 zstd/1.5.5 libidn2/2.3.4 libpsl/0.21.2 (+libidn2/2.3.4) libssh2/1.10.0 nghttp2/1.53.0

Platform: Manjaro Linux, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
Date: May 13 2023 09:24:47
wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.81.0
OCC: 7.6.3
Curl: 8.0.1
ngspice: 40
Compiler: GCC 13.1.1 with C++ ABI 1018

Build settings:

Do you have additional custom rules in use?
Are you sure that VBAT has the correct netclass assigned? (click the via – look at statusbar: “resolved netclass”).

Instead of guessing it’s always much easier if you attach the project (as zipped archive from kicad manager–>File–>archive project). You could also delete all unnecessary symbols/footprints except the relevant vias/tracks if there is some confidential content.

1 Like

Thanks, it is solved.
I had an old custom rule in use, forgot about that one. I still don’t understand why that rule had an impact on the fill zone, as far as I understand it should only apply within the courtyard of U701 and definitely not on inner layers. But it was the first time I even used a custom rule so probably I messed up.

(version 1)

(rule "BGA neckdown"
   (constraint clearance (min 0.099mm) (opt 0.1mm))
   (condition "A.intersectsCourtyard('U701')"))

only guessing (I’m no expert regarding the rule-system, I use only simple netclass-rules): the clearance applies to this rule because the zone itself is probably intersecting (flowing through) U701.

1 Like

After testing I can say you are right about the intersecting thing

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.