[SOLVED]Fill multiple zone

Hi evrybody,
I have new problem with kicad 5.1.8 and 9
I use 2 kind of grounds. It’s 4 layers pcb.
On top layer, the 2 grounds are OK. There names are Earth and Ground.
On bottom layer Earth is OK but Ground don’t want to work.
On top inner layer, Ground don’t want to work and on bottom inner layer power don’t want to work :frowning :frowning:
But, if I select Earth or +VCC or +9V it’s OK !!!
Have you got any idea ?
Thanks
Best regards

Top layer

Top inner layer

Bottom layer

Sorry when you say “does not work” please describe what you mean?. In detail; exactly what does or does not happen? Maybe your screen shots make it obvious to someone but not to me…

Because there’s no Pad nor via on the bottom layer, that is connected to GND.
Please note that your Top layer fill on the left is connected to GND

F#@$ !!!
Thank you fred4u.
Why, but why ?
Now it works !!!

Kicad fills the zone only if it’s connected to its net.
It can be either a pad, or a via.
Check if your zone setting is what you really want.

1 Like

In normal situation the user should not want to fill zone areas which aren’t connected to any pad directly or indirectly. Each area which is filled should be connected to the rest of the net. This is logical because every part of the net should be connected to the rest of the net, be it track, pad or filled area. It’s also practical because isolated copper areas aren’t recommended for electrical reasons.

Sometimes this is confusing when a user wants to create a plane and it isn’t filled at first. It’s a large area which should work as a GND or other reference, after all. But in the end it’s just a filled area which should be connected to the rest of the net (through a pad, track or via) before it is filled.

2 Likes

Hi stefkpl

As fred4u mentioned earlier, When the filled zone area is not connected to any component or via it will show up as blank and not a filled copper pour.

You can see in this image that the filled zone area shows up as a cross hatched outline. This is because it is not connected to a pad or via, or a net.

As there is no net on the inner layer and no vias are going to the inner layer connecting the ground, filled zone areas wont be visible.