[SOLVED] Errors importing from Eagle

I’m importing a schematic from Eagle (it was not made by me, I can’t release it).
I have to work on it.

But I get immediately an error.

Here how I import the schematic

I select the destination, an empty directory:

In EESchema:


Where am I wrong please?

just a guess: false eagle format.

During 30years of eagle-development there were different eagle file formats used:

  • binary file format with eagle version <= 5.x. Not working with kicad.
  • XML-file format from eagle v6/v7. These are the files that kicad can read (with more or less success).
  • new file format with the autodesk-takeover. Not working with kicad.

The XML-files start typically with:

<?xml version="1.0" encoding="utf-8"?>

Following your indication, I asked the version he used. Indeed it was old.
He sent me now the version made with 9.x.x and it worked out.
Not greatly (I had several errors to correct, tons of warnings for troubles with silkscreen) but it worked out.
Strangely enough,; the PCB Boundaries were not imported, but it was easy to re-design the PCB contour.

Thank you so much for your support

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.