[SOLVED] Edit/Moving a locked footprint?

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the KiCad.info forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

When locking a footprint in PCB Editor I’m sure at one stage I could select it and move with overwide, or edit and remove the unlock.

Once the footprint is locked I cannot click on it to select (And then edit/move etc)

The only way is seems is to search for the footprint, which then highlights the footprint. Cancel the search window, and can then right click and edit to unlock.

Is this a intended feature?

Application: KiCad PCB Editor x86_64 on x86_64

Version: 7.0.2-6a45011f42~172~ubuntu22.10.1, release build

	wxWidgets 3.2.1
	FreeType 2.12.1
	HarfBuzz 2.7.4
	FontConfig 2.13.1
	libcurl/7.85.0 OpenSSL/3.0.5 zlib/1.2.11 brotli/1.0.9 zstd/1.5.2 libidn2/2.3.3 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.49.0 librtmp/2.3

Platform: Ubuntu 22.10, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
	Date: Apr 17 2023 07:57:55
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.6.3
	Curl: 7.85.0
	ngspice: 38
	Compiler: GCC 12.2.0 with C++ ABI 1017

Build settings:

Does your Selection Filter at the bottom right allow Locked objects?

Thanks, that was it. Didn’t even know about the selection filter. Why am I only finding out about it now? :slight_smile:

It’s ok, there’s always a first time. :+1:

1 Like

By the way the setting to do it automatically is here

But I don’t find it a good idea on complex board to reflood the zone after each track drawn.

That’s for a different feature. But funnily enough I was wondering why mine stopped working a few weeks back. I don’t recall disabling it, and couldn’t find how to re-enable.

2 things learned today :slight_smile:

Why do you say it’s a different feature. When you enable the auto refill zone. Kicad will refill the zone after you draw a track for example. Just as if you had press the B key to start the refill manually.
Or did I miss something? As I said, I’ve seen the option and I’ve never used it, just once now to try it.

The original question was for moving a locked footprint, nothing to do with auto filled zones.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.