[Solved]Created footprint


#1

Hi all,

I have created a footprint in footprint editor and save footprint using add footprint libraries wizard, select the .pretty folder, the status stated OK and format is KiCad. And I put it to global library configuration so that next time when I doing another project I could call out the component.

In the footprint libraries manager I have the LTC3784

and I restart KiCad and open my project I still could not find the component in eeschema.

Do I have to create the symbol in the schematic and at the same time with the footprint?

Am I missing some steps?

Or do I just follow this link http://store.curiousinventor.com/guides/kicad/new_components

Thanks in advance.


#2

How did you try to access the footprint in eeschema?

Did you use cvpcb (The table like thing to set the footprints for all components)
or did you try to set the footprint field directly (library browser.)

If you used cvpcb have a look at the filter settings.

That tutorial seems really out of date

Maybe have a look at the getting to blinky tutorial series:
https://contextualelectronics.com/courses/getting-to-blinky/


#3

I using place component in eeschema or do I have to use another tool to call out the component?

No I did not use cvpcb.


#4

Place component (in kicad stable) does place symbols not footprints.

For more details about the difference between footprints and symbols please have a look at this post of mine: (click the post title to get to that topic or the arrow at the right to read only the linked reply.)


#5

Thanks @Rene_Poschl I am watching the tutorial video you have post.

I’ll follow the steps you have mentioned

Thanks thanks


#6

For the footprint assignment step i made a different post. (I did not find it when i made my other replies. It might still be helpful.)