[Solved] Component looks different in eeschema (compared to lib editor)


#1

This is weird.
I have created a component that looks like this in the library editor:

When I use this component in eeschema, it looks like this (Note the position of the Reference and the Type fields.):

I am running the most recent nightly build.

Versioninfo:
Application: kicad
Version: no-vcs-found-200df95~58~ubuntu16.04.1, release build
Libraries: wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-78-generic x86_64, 64 bit, Little endian, wxGTK

  • Build Info -
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.58.0
    Curl: 7.47.0
    KiCad - Compiler: GCC 5.4.0 with C++ ABI 1009
    Settings: USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=ON
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON

Is this something I did wrong in the component, is it expected behaviour for some reason unknown to me, or is it a bug?

m


#2

Did you define the line with in the lib editor?
(If you set it = 0, The default line width is displayed which could explain this behavior. I don’t know where the default line width is set. Maybe somewhere in the project settings?)


#3

A nightly I used from February did relocate REF/VAL fields half a page to the left/down.
The current one doesn’t do this…

Anyhow, check this:


#4

I did not touch it. It is set to 6mils.
m


#5

That’s it, @Joan_Sparky.
Phew :slight_smile:
Thanks. Eeschema is now behaving like expected.

m


#6

It seems i was not totally awake when i wrote my reply. (I did not see your mentioning of the problems with the value/reference field. I thought to see that the line width is totally different between these two screen shots. This might have been a problem on my side.)
Sorry for the confusion.


#7

Happens to me all the time :slight_smile:
m