[Solved] Clearance to via in zone not respected?

Hello,

I’m trying to keep a certain clearance to vias (ideally different for inner and outer layers). When I change the clearance in the zone setting and re-pour, nothing changes. I even went to extreme values like 1mm and the clearance ring around the via remains unaffected. Any idea what could be wrong? What would be the correct way of doing this?

cheers
dominik

The clearance can be defined in a lot of different ways. Each netclass (so also the via) has it’s own clearance, just as zones. On top of that clearance can be overridden either by pads, whole footprints or custom rules.

1 Like

Sure but shouldn’t the largest of the defined clearances be the one that is binding? In my case for example, the zone clearance?

cheers
dominik

custom rules override the netclass and zone-settings.

You could select the via and the zone, than run Inspect–>Clearance resolution. The opened window shows all netclasses/rules/constraint and tells: which are ignored, which are applied and which is the clearance-endresult.

Or maybe attach your archived project so someone can look into the board.

3 Likes

That is a wonderful feature. Found exactly the custom rule that was at fault. Thanks!

cheers
dom

2 Likes