[SOLVED] @ChrisGammell et al: Font display problem


since a few weeks, I have a strange problem with the font that’s used for the forum. Everything is in displayed in a narrow italic font that makes things hard to read. Here’s a screenshot:

This also happens on some other websites and with different browsers (Firefox and Konqueror, so two different rendering engines) on two diferent machines, both are running Debian stable. It also happens with privacy plugins (adblockers, script blocking, etc.) disabled. Since I see this on different websites, my suspicion is about a font being loaded from a third party server that is inexplicably blocked on both machines but am unable to pinpoint it.

Any hint is appreciated.

I’m using Win7 and both Chrome and Opera display this web page same as always; so I don’t think it is an issue with this web forum.

Works fine in firefox under fedora 23 and also under fedora 26

This is an old thread on font issue…
It seems it was related to a corrupted registry

Thanks for the first replies. I am pretty sure it has something to do with both of my Debian Linux installations and probably an update broke a config file. All other Windows and Linux machines (physical and virtual) that I have running display the websites in question just fine.

It’s just that this forum is the first website where I noted this behavior since its appearance is familiar to me.

I’ve tried all kinds of font config options for the browsers, reinstalled fonts, etc. but to no avail.

I would like to avoid switching my main desktop OS just because the browsers don’t display websites correctly, so I’m hunting for the source of the problem. Like I wrote I suspect a third party font (like Google web fonts) to be loaded from a server that can not be reached for unknown reasons. Knowing the type and source of the font may lead to an idea what’s broken in my configurations.

I use Debian stable and don’t see this issue.

I still don’t know what went wrong, but deleting all content of /usr/share/fonts and reinstalling all fonts solved the issue. Hope it stays this way.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.