[SOLVED] Can't see anything in the schematic editor

I have installed Kicad in my Arch Linux using this command, sudo pacman -S kicad. But I didn’t install kicad-library and kicad-library-3d libraries. I downloaded them from the Gitlab repo. I tried to add a symbol. The popup window that appears to select symbols from opens and I find the symbol I need but “No footprint specified” is shown instead of its footprint.

I deleted these manually added symbols and searched to discover these packages

  • kicad-library
  • kicad-library-3d

These two packages were successfully installed but Kicad didn’t read them. So I removed some config files to get the popup window to choose my libraries again as if this is the first time I open Kicad:

  • ~/.config/kicad/6.0/fp-lib-table
  • ~/.config/kicad/6.0/sym-lib-table

The same issue is still happening.

Help, help!!!

Application: KiCad Schematic Editor

Version: 6.0.0, release build

Libraries:
	wxWidgets 3.0.5
	libcurl/7.80.0 OpenSSL/1.1.1m zlib/1.2.11 brotli/1.0.9 zstd/1.5.1 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.0) libssh2/1.10.0 nghttp2/1.46.0

Platform: Linux 5.15.12-arch1-1 x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Dec 30 2021 00:19:57
	wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.78.0
	OCC: 7.5.3
	Curl: 7.80.0
	ngspice: 35
	Compiler: GCC 11.1.0 with C++ ABI 1016

Build settings:
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

I forgot to mention that I boot-ed into windows (I have a dual boot of Windows 10 and Arch Linux) and installed Kicad. Everything is OK there, I built my circuit and simulated it.

KiCad 6.0 renders correctly when I changed my (Schematic Editor > Display Options > Rendering Engine) option to “Fallback graphics”.

image

“No footprint specified” has nothing to do with it, that one is not a problem and means that there’s no one default footprint for the generic R symbol because there are myriads of possible alternatives. You can just choose one from the dropdown list or change the symbol’s Footprint field afterwards.

The problem is somewhere in your system, graphics hw/drivers. I don’t know how Arch handles them and how well your specific setup is supported by Arch.