[SOLVED] Can't connect trace to pad

The pad on Q1 Pin2 is on the same net as the partial trace to the left. But, it will not let me make the connection. What am I missing?

Thank You!

The thin yellow circular lines are the culprit as they set the clearance. Overlapping clearances make the forbidden connection

Clearance can be set in 3 levels: board, footprint and pin.
Seeing those big clearances for all pins makes me guess you have a large general clearance set for all the board

Hi @awardblvr
Not the problem you mention, but you have an extremely large Pad Clearance.
This can be changed in Pad properties > Clearance Overrides and Settings > Pad Clearance.


I don’t know of a way to alter the pad clearance in bulk. Maybe others may help.

What is your Kicad version?

Kicad 7

Application: KiCad PCB Editor x86_64 on x86_64
Version: 7.0.6-0, release build
wxWidgets 3.2.2
FreeType 2.13.0
HarfBuzz 7.3.0
FontConfig 2.14.2
libcurl/7.88.1 (SecureTransport) LibreSSL/3.3.6 zlib/1.2.11 nghttp2/1.51.0
Platform: macOS Ventura Version 13.4.1 (c) (Build 22F770820d), 64 bit, Little endian, wxMac
Build Info:
Date: Jul 6 2023 22:01:07
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.82.0
OCC: 7.7.0
Curl: 7.77.0
ngspice: 38
Compiler: Clang 13.0.0 with C++ ABI 1002
Build settings:

@awardblvr : Do you have followed pedros advice and checked all the clearance-settings:

  • board: File–>board setup–>design rules–>Constraints–>minimum clearance
  • netclass: File–>board setup–>design rules–>netclasses–>clearance values for all netclasses
  • footprint: double-clicking one of the footprints with the big circles -->get footprint properties dialog–>clearance overrides pane–>pad clearance (note the remark regarding value==0)
  • pad: double-clicking one of the pads with the big circles -->get pad properties dialog–>clearance overrides pane–>pad clearance (note the remark regarding value==0)
1 Like

Thanks … was just gonna ask… Now walking through each of those… MANY thanks… I’ll reply shortly.

:dart: (Bulls’eye!) It was the first one, first value, “minimum clearance” was 3, now .1


1 Like

Unrelated to the question, but I would make those narrow tracks wider unless you have a specific reason not to do so. I am guessing that you have 0.2 or 0.25 mm. I would use at least 0.5 mm unless clearance or other issues dictate otherwise. Actually I use 1 mm as sort of a default, but yes I often need to make them narrower in order to squeeze through a gap or crowd a bunch of tracks into a small space. Or to avoid being larger than the pad to which I am connecting.

Ha… Funny… I just had this intuitive feeling, so I began widening them this morning … Started with power and ground → .4 mm… (only a few signals here, all low speed, all under 5mA each.)… I guess I’ll beef them all up to > .5mm based on your suggestion since I’m going to etch this SS board myself. Thanks! (What a great community!)

If you’re etching PCBs yourself, don’t go below 0.5 mm as a general rule. Tight squeezes (eg, between pins) 0.3 mm is possible, but critical. Just speaking from experience.

1 Like

No, please do not etch yourself.
It’s bad for your skin texture.
Etching PCB’s is much safer and productive.

Quote from original retroactively added.


Ha! A quick edit just killed your silly remark :rofl:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.