[Solved] Cannot route two overlapping traces

Dear Team,

I am a newbe to Kicad so please forgive me if this is obvious.

I run Kicad V6.0.2

When I try to route parallell traces (one trace per layer), connecting the same through hole pads, Kicad deletes the previous routing (in another layer) automatically.

Is this a setting somewhere? I understand it is not logical in that you basically have two connections doing the same thing, but I needed parallell traces to handle high currents.

Many thanks for feedback.

Welcome. You’ll find the setting answer in this post:

And do upgrade to 6.0.9, there’s no reason not to.


Thank you for a fast and kind reply!

Kicad is impressive!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.