[SOLVED] Building KiCad v5 from sources: "Could NOT find OpenMP_C (missing: OpenMP_C ...)"

Hi folks! This is my first message so I kindly welcome you all )

I’m trying to build KiCad from sources in order to get the latest 5th version. I’m far from being expert in building from sources (escpecially with CMake) so I need an advice. Could anyone to help me resolve the missing OpenMP_* flags and shed light on why they are needed?

Here is the output after cmake was executed:

-- Kicad install dir: </usr/local>
-- Could NOT find OpenMP_C (missing: OpenMP_C_FLAGS OpenMP_C_LIB_NAMES)
-- Could NOT find OpenMP_CXX (missing: OpenMP_CXX_FLAGS OpenMP_CXX_LIB_NAMES)
-- Could NOT find OpenMP (missing: OpenMP_C_FOUND OpenMP_CXX_FOUND)
-- Check for installed GLEW -- found
... [everything else seems ok]
-- Configuring done
-- Generating done
-- Build files have been written to: /home/timur/Desktop/kicad/build

I don’t even know if they somehow impact the program itself, but the building process was certainly slooow! :slight_smile: I have already posted the message alike in the Void forum but get no response so I hope to get it here :sunny:

I use Void Linux as my primary system. I’ve checked if suitable libraries are installed ([*] means installed):

xbps-query -s[earch locally] openmp
[*] libgomp-7.3.0_3       The GNU C Compiler - OpenMP v4.0 library
[*] libgomp-devel-7.3.0_3 The GNU C Compiler - OpenMP v4.0 library - development files

As a reference for resolving dependencies I used this and this.

Just in case, how I did it:

git clone https://git.launchpad.net/kicad
cd kicad
git checkout 5.0.0-rc2
mkdir build && cd build
sudo xbps-install -S python wxWidgets-devel wxPython-devel python-devel glew-devel cairo-devel glm libcurl-devel boost-devel oce-devel swig libgomp-devel
vi build.sh:

export CXXFLAGS="$(wx-config --cxxflags)"

cmake -DCMAKE_C_COMPILER=clang \
      -DCMAKE_CXX_COMPILER=clang++ \
      -DPYTHON_SITE_PACKAGE_PATH=/usr/lib/python2.7/site-packages -DPYTHON_DEST=/usr/lib/python2.7/site-packages \
      -DCMAKE_BUILD_TYPE=Release \

... (log is above)
make -j8
sudo make install
# program runs ok


OpenMP is optional, but not supported with clang.

1 Like

I missed to say that I’ve installed clang only for the case (somewhere in the net was said I need to use it instead). Doing the same process without these flags give the same result.

What exactly gives OpenMP to KiCad?

Read the link…

Yesterday I were pretty tired. Sorry, I’ve missed the link. Got it! Thank you a lot.

Parallel processing.
Used in Pcbnew for connectivity and fill zones. Used in 3DViewer for rebuild the 3D board and for Raytracing render.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.