[SOLVED] Bug confirmation in pad properties required

Select pad properties (any pad, smd, tht, a mounting hole, copper heatsink, Kicad or personal libraries … anything)
Select a shape that allows both X & Y to be altered.
Instead of “right click” & “select all” on the pad size, place cursor at far right of the size and use the backspace to remove that number.
The right of the cursor in the X value remains empty, the right of the cursor in the Y value has one or two random numbers generated.
Select Hole, perform same experiment, same result with one or two random numbers generated.
If Hole shape is changed so Y value can also be altered, both X & Y have random numbers generated.
Same result with mounting holes and copper under ICs.

Please confirm before I open a bug report.

Edit: this is both 6.0.10 & 6.99

Not reproduce able on version as below.
Cheers

Application: KiCad PCB Editor x86_64 on x86_64

Version: (6.99.0-5204-g761b75dc55), release build

Libraries:
wxWidgets 3.2.2
FreeType 2.11.1
HarfBuzz 2.7.4
FontConfig 2.13.1
libcurl/7.81.0 GnuTLS/3.7.3 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.13

Platform: Ubuntu 22.04.1 LTS, 64 bit, Little endian, wxGTK, xubuntu, x11

Build Info:
Date: Dec 26 2022 10:36:13
wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.81.0
ngspice: 31
Compiler: GCC 11.3.0 with C++ ABI 1016

Build settings:
KICAD_USE_EGL=ON
KICAD_SPICE=ON

I can also not confirm this.
Your description is also not completely clear to me.

I assume you are doing this in the PCB editor, then select a pad and edit it’s properties:

I did notice that the rightmost 15 or so pixels inside the box can not be used to put the cursor inside the box.

I hadn’t tried pads with whole number values.
Could you try something with decimal points please, such as:
ksnip_20221226-233606

I think I can explain your “random numbers”. I think there are no random numbers generated, but the text string simply does not fit in the entry box, so the last two or so digits are not shown until yo make the text string shorter.

If I copy both the X and Y coordinates from this box:

image

and then paste them in a text editor, they both show as “59,05511811”.

1 Like

They are not random numbers, Kicad gives a resolution to 8 decimal places. The X value shows 8 decimal places, but the Y value only shows 7 decimal places in this instance. Sometimes only 6 decimal places are shown, hence, on those occasions there are 2 numbers after the cursor.

Sorry for all the trouble. No bug exists. i thought this was a bit weird.

I realised the problem, or lack of problem as you were writing.
Thanks for the post.

I tried to reproduce in the second latest nightly 6.99, and I think what paulvdh describes is what is happening.
I don’t get any other random numbers, whether in millimeters or mils. In both cases I had decimal comma though, not decimal dot like jmk, so there is a theoretical possibility for some difference in behaviour there, though I think unlikely.

This is what I tested with:

Application: KiCad mönsterkortsredigerare

Version: 6.99.0-1.20221224git826508e.fc36, release build

Libraries:
wxWidgets 3.0.5
FreeType 2.12.1
HarfBuzz 4.0.0
FontConfig 2.14.1
libcurl/7.82.0 OpenSSL/3.0.5 zlib/1.2.11 brotli/1.0.9 libidn2/2.3.4 libpsl/0.21.1 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.51.0 OpenLDAP/2.6.3

Platform: , 64 bit, Little endian, wxGTK, KDE, wayland

Build Info:
Date: Dec 24 2022 21:28:06
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.82.0
ngspice: 38
Compiler: GCC 12.2.1 with C++ ABI 1017

Build settings:
KICAD_SPICE=ON

1 Like

That will teach me to change methods.
Normally it is right click, select all, when changing pad sizes. Never paid much attention to the number of decimal places shown in the pad or hole sizes.

At least I won’t be wasting developers time.