[SOLVED]Automatic footprint assignment in v6 (equ file)

Hi. I have a problem with automatic footprint assignment from the equ file. In version 5 works fine. In version 6.0.4, with the same settings, it reports that “file equ not be found in the default search paths”. After reading the documentation i don’t know what that means.

Perhaps the KIPRJMOD envar is not getting resolved in this case?

1 Like

I would use absolute path in any case, you hardly want to tie your hands in that kind of relative folder structure:

  • D:/temp/aveco/pcb/project1…
  • D:/kicad_v6_usr/a6_table/file…

so that you always have to have the projects 3 levels deep relative to the equ files.

Thank you for answer. I tried to place the file and set the absolute and relative path, place it in the root project and also via KIPRJMOD, etc. The latest version of Kicad 5 has no problem.

I tried using the Add button and then editing the * .kicad_pro parameter file in “cvpcb” → “equivalence_files” the following:
project root:

“$ {KIPRJMOD} /a6_table.equ”

absolute path:

I also changed the slashes .

I feel like that the path is not being passed on correctly. In the window where you can add an equ file with the Absolute / Relative path option, the file can be edited back at any time (button Edit File) - even if I close and reopen the project. If the file exists or even delete it, I will get exactly the same result - see the picture above.

Reported and acknowledged as an error with high priority (6.0.5).


Hello and welcome @letadyylko

It is worth including the link to the report so others who are interested can easily follow its progress. :slightly_smiling_face:


1 Like

I reported a bug for the first time. Thank you for the warning.

Certainly not a warning… just a courtesy to any who wish to follow the bug outcome. :slightly_smiling_face:

I understand, thank you :slightly_smiling_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.