[SOLVED]7.0.0rc1: PCM doesn't work anymore?

PCM fails for all plugins listed as the links given seem to be wrong.

Example (holds true for each plugin in the PCM):
does not exist. The problem is the …/download/…
Editing the URL and removing that works.

Can you confirm?

Works fine for me. Url you copied is cut off, that’s why it does not exist, not because of /download/

What error are you getting?

No,I just shortened it here

Just an example:


That’s some kind of network issue. Is your internet connection through some kind of proxy maybe? Or maybe you have a firewall that needs to add kicad.exe to exceptions?

In a pinch you can always just open the url in your browser and download the file, then install in pcm from file.

No proxy. And I didn’t change anything in my system. It’s just strange.

Sure, but that’s no the way to go, or is it?

BTW, this one works:

Yes, I’m just saying if you need a plugin NOW, there’s a workaround.

If a plugin hosted on gitlab works then maybe your local github CDN has temporary issues.

Sort of…, that’s what I came to think, too.

Thanks for your effort, however. Let’s put it to rest for now.


I also just installed InteractiveHtmlBom for V7.0-rc1

I can not run it though because there is currently some versioning problem with wxPython.

Application: KiCad x86_64 on x86_64

Version: 7.0.0-rc1-unknown-c5ef51d688~164~ubuntu20.04.1, release build

	wxWidgets 3.2.1
	FreeType 2.10.1
	HarfBuzz 2.6.4
	FontConfig 2.13.1
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux Mint 20.3, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Jan  7 2023 20:32:58
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.68.0
	ngspice: 38
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:

Ok. If you like to disclose: are you in Europe? 'Cause Belgium and Austria did not work.

1 Like

Just for fun I installed 6.0.2 → works.
Reinstalled 6.0.10 → fails.
7.0.0rc1 → fails.

Not sure the evidence supports the broken CDN therory, but anyways. Back to manual installations.

1 Like

There is another discussion about the issue and @marekr solved it there. Thanks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.