[SOLVED] 5.99 Update symbol from library clears reference/value?

Running the latest 5.99 nightly and not sure if the following is a bug or expected behavior. (First time I am trying this so probably not specific to latest nightly)

After installing nightly updates I notice sometimes that ERC gives a warning that “xxx has been modified by library”

If I then edit the symbol and select update symbol from library, and then click update, the value and reference is cleared.

Is this expected behavior? I would expect the values to be kept and only the symbol updated?

Screenshot from 2021-11-13 11-47-13

Uncheck “Update/reset field text” and try again, however, since the reference/value are not selected among the fields to update/reset, this becomes confusing/suspicious… because Footprint is neither reset nor updated, thu it is checked on the right.

image

Perfect, thanks. That did it.

Guess I need to pay more attention to the fields on the screen :slight_smile:

Actually that did not do it. Selected fields on the left should be updated/reset as long as you have checked “Update/reset field text”. Since Reference and Value are not selected, they should not be reset, only the selected fields should be updated/reset. Also note that footprint is checked on the left, and “Update/reset field text” on the right is also checked and footprint is not being reset.

If you have nothing checked on the right, nothing concerning fields/attributes will be updated/reset.

There seems sth wrong with this behavior. I checked V5.1.12 and it works as expected, appears to be a bug in 5.99

1 Like

This is a very recent bug. I just fixed it.

8 Likes

I believe this is solved.

Confirmed. Its working on the latest nightly.