[Solved] 5.99 - Graphic polygons displayed unfilled while they're correctly filled in the 3D viewer

Hi

I have several graphic polygons on the front silkscreen that appear unfilled in Pcbnew while they’re correctly filled in the 3D viewer.

I searched for an option/command to fill/unfill polygons in Pcbnew without success. Is it a bug or a PEBCAK ?

Thanks !

Application: Pcbnew

Version: (5.99.0-3299-gfc1665ff2), release build

Libraries:
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0

Platform: Windows 7 (build 7601, Service Pack 1), 32 bit, Little endian, wxMSW

Build Info:
Date: Sep 10 2020 22:11:12
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OCE: 6.9.1
Curl: 7.71.0
ngspice: 32
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON

As a very simple test I just put a polygon on F.Silk:
image

Then I noticed you are on V5.99, while I have V5.1.6. which makes comparison pretty much futile I’m afraid. Me guess that putting V5.99 in the title for V5.99 issues would be a good idea.

But still:
On which layer is your polygon? Could that be the issue?

They’re on the front silkscreen like yours.

I really suspect a switch somewhere but can’t find it.

Graphic polygons can’t be unfilled like zones. I suspect this is a bug.

Could this be the bug which affected copper zones? https://gitlab.com/kicad/code/kicad/-/issues/5594

Here’s the file - I don’t see anything suspect (except the wrong indentation of the first point of each polygon). The polygons are around line 1650.

moas_ii_adapter.kicad_pcb (275.2 KB)

Good catch ! For a rectangle, one of the two dimensions must be >= 10mm to get a filled polygon. If not, it remains unfilled :wink:

That bug was fixed, so you should try with a newer nightly build.

Indeed. The latest nightly is OK :+1: Thanks !

1 Like