[Solved] 3D Viewer 7.99: Did the flip function change?

Recently, when flipping a board in the 3D viewer, there is a sequence

  • original board
  • board rotated 180°
  • board flipped
  • flipped board rotated 180°
  • restart

Is this new or simply a bug?

Looks good in:
Version: 7.99.0-unknown-ace7cbddfe~172~ubuntu22.04.1, release build
Date: Oct 15 2023 03:18:17

3D view with “f” just flips the board. Same result as rotating the board 18 times with the Y icon. (From my way of seeing things, Y rotation and Z rotation are interchanged)

I used the icon

Same result as F. It rotates 180 degrees around the Z axis.

Ok, thx. Anyways, here’s the video, just in case someone else wants to see that.

This is not what happens in my today’s copy. It works as expected.

I happen to have 7.0.7rc1 and probably yesterday’s 7.99, both work correctly. I didn’t find any Preferences which logically might affect this.

With an old board 7.0.8 does not show the effect, 7.99 does. I cannot open my recent 7.99 boards with 7.0.8 for obvious reasons.

Thanks for checking anyways.

I just recompiled the latest 7.99 code, no problem. Try again with the next nightly build if you use nightly builds.

Myteriously solved by today’s nighly, although I cannot see any commits that might be related.

This was related to a change in quaternion data layout in glm library, which vcpkg had updated to an unreleased version. The glm version has been pinned to the working one.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.