[solved] 3d shapes not showing up in rc3 (debian testing)

For the past 3h I’ve been reading all posts and watching tutorials about getting the 3d shapes for footprints to show up - and all I get is a bare PCB no matter what I do.

I’ve verified that the 3d models are installed (/usr/share/kicad/modules/packages3d), the shape is correctly set in the footprint properties and I made sure that all “3D model visibility” in the 3d viewer preferences are checked - still no dice.

Even when I use “Add 3D Shape” in the footprint properties the preview window stays blank (black), regardless of which shape (wrl or step) I select. Same if I hit “Alt 3” in the footprint editor, no 3d shapes other than the pcb.

I opened some of the 3d shapes files with FreeCAD and they do contain the proper shape. I’m at the end of my wits - any help is much appreciated!

Edit: added version info -----------------------------------------------------------------
Application: kicad
Version: 5.0.0-rc3+dfsg1-1, release build
wxWidgets 3.0.4
libcurl/7.60.0 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.4 libpsl/0.20.2 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.32.0 librtmp/2.3
Platform: Linux 4.16.0-2-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.62.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.60.0
Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:

I haven’t paid lots of attention to this topic in terms of detail but let’s start with was there a previous install that might have a stale configuration file?

I have done a rm -rf ~/.config/kicad
I got all the messages about this being the first time kicad running and all that - although I did install the 3d packages afterwards (have restarted kicad since though).

This is #903291. It’s fixed in -2 that should be migrated to testing today.

Please try to verify first on https://bugs.debian.org/cgi-bin/pkgreport.cgi?repeatmerged=no&src=kicad to see if the issue isn’t already know.

1 Like

It sure is - I literally did update my debian distribution before posting - and after seeing your post I tried again - sure enough there is a new version of kicad and the problem is fixed!

As far as I’m concerned, that is awesome and prompt customer service! :smile:
Thanks a lot - and sorry for the noise.

1 Like

One more question - why is “Export -> Step” disabled?

Is it disabled for all projects?
If it is it might have something to do with how your version is compiled. (In todays nightly on ubuntu this tool is accessible.)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.