[SOLVED] 3d modules not visible on Kicad 7 snap and Ubuntu

I installed on Ubuntu the Kicad 7.0 snap, I’m on the PCB editor and I’m not able to see the 3d component. If I activate the 3D viewer (Alt+3) I only see the 3D of the PCB without components.
I tried to add the 3D model to the component (pcb editor–>right click on the component–>propriety-3D model) and never happened. I can choose the 3d model .step from the list but the image don’t appear on the 3D viewer.

only for the first power on of Kicad, when I try to add a new link to the 3D model (pcb editor–>right click on the component–>propriety-3D model–> folder icon on the left between the “+” and the trash icon) appered the error message below

21:59:49: can’t open file ‘/var/lib/snapd/desktop/applications/snap-store_ubuntu-software-local-file.desktop’ (error 13: Permission denied)
21:59:49: can’t open file ‘/var/lib/snapd/desktop/applications/snap-store_ubuntu-software.desktop’ (error 13: Permission denied)

any suggestion?

Application: KiCad PCB Editor x86_64 on x86_64

Version: 7.0.1-3b83917a11~172~ubuntu22.04.1, release build

wxWidgets 3.2.1
FreeType 2.11.1
HarfBuzz 6.0.0
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.14

Platform: , 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
Date: Mar 15 2023 03:29:40
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.87.0
ngspice: 38
Compiler: GCC 11.3.0 with C++ ABI 1016

Build settings:


you may need to use ‘mount bind’ to have access to KiCad 3D models path

Thanks Maui,
I tried and doesn’t work

at the end I solved, I cancelled the snap and installed Kicad following the instruction on the Kicad website

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.