Solid Vias (not thermal) on only one layout pad

I have a ground polygon that has thermal relief for vias. That’s what I want, except for one connection to a pcb antenna. How do I make that one via/PTH pad solid?

Tried “Connection to Copper Zones” as “Solid” (see picture), but I still have thermal relief for that via.

Still have thermal relief:

Sorry, this is not an answer to your question, but a question of my own, out of interest. Why do you want a thermal on a via?

Do you have recalculated the zone-fill after changing the setting?

1 Like

I do NOT want a thermal on a via. Trying to get rid of it.

How do I do that?

I did shutdown and restart pcbnew. Will that force the “recalc”?

But, in general, for a PTH hole (not really via) you want thermal relief so it’s easy to solder.

Otherwise, a connected ground plane acts as a heat sink. Takes a lot longer with the soldering iron to get the pad hot enough for good solder reflow (when hand soldering).

So, I turned off thermal reliefs for the polygon. Then turned it back on.

This must be the equivalent of the “recalculate zone” you asked about, because now the PTH pad does not have thermal relief.

Thanks!

Do you have recalculated the zone-fill after changing the setting?

How do I do that? I did shutdown and restart pcbnew. Will that force the “recalc”?

No, restart pcbnew doesn’t changes the zone filling.

Edit–>Fill all zones. This menu-entry shows also the assigned hotkey for this action.

1 Like