Solid fill zones on copper layer never filling

I now have 6.0.5 and I have never had this problem before. Zone won’t fill no matter how many times I hit “B”. Checked the Properties and all looks right. Stays hatched and won’t connect pins/vias to the same net. The rats stay. Help!

Double check that you actually defined the correct net in the zone properties.

Beyond that, I don’t know what else to tell you based on the limited information you provided. Screenshots and/or the project zipped and uploaded may help us spot something that you missed. Spend some time on the forums reading other threads and you’ll be able to upload more than one picture per post.

I have a feeling that the reason I can’t upload is because these are my first posts. I’ve been using KiCad for some years and have never had this problem. Yes, the GND net is defined. The shape is on the top copper layer.

You should be able to upload attachments now.

Ok, I think I figured it out. I had no parts connected to the shape on the net that I assigned to the shape. Once I brought a part over and put the ground pad of a cap on one of the shapes, it filled in. Kind of weird.

I understand you experience this as weird / unusual, but it is actually a useful feature.
It is not useful to have unconnected copper in zones, and when a part of a zone becomes unconnected, for example because it is cut off by tracks crossing it, then KiCad does not fill that part of the zone anymore. It also gives you visual feedback.

Did I say weird? I meant “feature rich”! :rofl:
I had just never noticed it before since I would do a full schematic first, then bring parts in and start placing, and THEN put ground pours in. I kind of did it the other way with minimal parts knowing how I wanted the layout to be first. NOW I KNOW. And you know what they used to say in the 80s, “knowing is half the battle”… :grin:

1 Like

This is the “remove islands” feature in the zone properties and you can change the default setting if you want to create unconnected copper with a zone.

Aha! The “remove islands” feature. Now that you say that, I totally understand why it is designed the way it is. I would probably never turn off the “remove islands” feature so I will just remember this in case it comes up in the future.

Thanks to you all!! :partying_face:

1 Like

Where is the “remove islands” feature in the zone properties? Hell, where is “zone properties”? I now need to make some shapes that are not connected to anything as I am doing an RF layout that requires this.

After adding a new copper zone, the Zone Properties dialog will appear. Also, right-click on any pre-existing zone and the dialog will appear too.

The “Remove Islands” control is in the lower-right corner of the dialog.

1 Like

Thanks to you all for all of the replies. It has helped me a lot in getting back up to speed in KiCad. :partying_face: