Solder mask covering pads, why?


#1

Hey everyone, I’m relatively new to KiCAD and I can’t quite understand what’s happening here:

I am using through hole components, and the footprints are set to use the pads on both the top and bottom copper layers, but when I export the board, and in the 3D viewer, it seems as if the solder mask is covering the bottom pads, but not the top ones. Why is it covering the bottom pads? Is this something I did wrong?

Does anyone know why this is happening? I can’t seem to find a solution…


#2

First of all, don’t use 3D renderings as the final authority for showing how a board will be fabricated. The board fabricator will work from the Gerber files, so when you notice discrepancies like this you should verify the situation with a Gerber viewer. (Regardless of what DRC or any other tools may tell me, I always do a final review with a Gerber viewer before I send a board out for fabrication.)

To resolve this situation I would bring up the affected footprint(s) in the Footprint Editor. Look at the parameters defined for each pad. Are they specified as through-hole pads? Are the appropriate check-boxes marked for ALL affected layers? Are there any values for Solder Paste Clearance or Solder Mask Clearance, that would over-ride the global values? You may find it helpful to compare the values and parameters from a known-good footprint, to a faulty footprint.

If you make any changes be sure to save them to your footprint library - either modifying the existing footprint, or creating a new footprint. (As difficult as it is to imagine, somebody may have had a valid reason for covering those pads with soldermask, so you might want to keep the footprint around.) Then do what’s necessary to update the footprint associations on your schematic, and swap out the new and old footprints on your board.

Dale


#3

I completely agree with dchisholm.
The 3D viewer is not the right tool for determining such things.
3D Viewer -> Preferences -> Realistic Mode
Might get you a bit loser to the way you want to view the PCB.

But for a more “authorative” view, use the layer selection menu on the right side of PCBnew to turn layers on/off to get a better view of what is really on each layer.
Edit the footprint etc. properties accordingly if anything is amiss.
But the generated Gerbers are always the last thing (and only really important) thing to check.

I found the reference manuals on the KiCad site quite good for looking up unknown details:
http://docs.kicad-pcb.org/stable/en/pcbnew.html


#4

You guys are both absolutely right, and I do not use the 3D viewer as my go to thing to see the final board, but I used it in this case because I thought that it best illustrated the problem I was having. That, and the fact that I am only allowed a single picture. Going forward though I will definitely use the Gerber Viewer.

dchisholm you actually solved my problem as well. The problem was that for some reason only the front technical layers were selected on the footprints. I have no idea why this is, but then again, I am using imported SparkFun Libraries so I should have checked it completely instead of simply relying on it to work.

I solved the problem by selecting the correct technical layers for both the front and back of the board.

Thanks to both of you guys for the help, I’ll definitely pass this on to others!

Cheers!


#5

PS, for better visuals you might want to change the colors for the 3D viewer to realistic instead of editor layer colors…


#6

For the moment, I’m using OSH Park for my prototype boards. They use purple for the soldermask on these boards.

I have changed the colors in the 3D viewer to more closely match what I expect my finished board to look like. I also mimic some of those colors in PcbNew.

By doing this I know exactly what layer/element I am looking at, without having to re-think it every time.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.